summaryrefslogtreecommitdiff
path: root/dev-python/junit-xml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/junit-xml
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/junit-xml')
-rw-r--r--dev-python/junit-xml/Manifest3
-rw-r--r--dev-python/junit-xml/junit-xml-1.9.ebuild28
-rw-r--r--dev-python/junit-xml/metadata.xml7
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/junit-xml/Manifest b/dev-python/junit-xml/Manifest
new file mode 100644
index 000000000000..f08dd8f15bc7
--- /dev/null
+++ b/dev-python/junit-xml/Manifest
@@ -0,0 +1,3 @@
+DIST junit-xml-1.9.tar.gz 11111 BLAKE2B e40914263421e7021d6bd697a03ae74b596d915479f24e8227d8b0b0bda51529df58f7aa54b27e981bb1df0aa36d7876f4f30fff8924188143bc4dd6b1d80b17 SHA512 73d5245f4a324485370e91d0d4d9a754133e0f90e5ad9ae7070bbb7aad29bee5fda4103548483358d536834c5fee9c8bd5fef79c4b66f905a2aeb0823ef02d22
+EBUILD junit-xml-1.9.ebuild 810 BLAKE2B 5c53fb8764f98e5ef7c408a9cff437eabea4dfb73671ecd31e5fdd452d9a7d674a44b307b407a0837253aaadcc033c62c9bca0580e5bb7b1f471d3652ca12a06 SHA512 04bb3940ce78871a8bac6dcb1c8e976a5fb422597245e3ac9fec71c1a501c60071f94322ca72b04fb789b5f342f114556168b7703404d7cdc6559ece11cd8ef2
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/junit-xml/junit-xml-1.9.ebuild b/dev-python/junit-xml/junit-xml-1.9.ebuild
new file mode 100644
index 000000000000..b6fa6e5bf110
--- /dev/null
+++ b/dev-python/junit-xml/junit-xml-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Create JUnit XML test result documents"
+HOMEPAGE="
+ https://pypi.org/project/junit-xml/
+ https://github.com/kyrus/python-junit-xml"
+# upstream fails both at uploading to pypi and making tags
+# https://github.com/kyrus/python-junit-xml/issues/69
+# https://github.com/kyrus/python-junit-xml/issues/31
+EGIT_COMMIT="19d3cc333d35dfd2d17d75c506336c15e5c6685a"
+SRC_URI="
+ https://github.com/kyrus/python-junit-xml/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S=${WORKDIR}/python-junit-xml-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/junit-xml/metadata.xml b/dev-python/junit-xml/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/junit-xml/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>