summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
commitbfc2a8298cab03d289dc2cfed63308396fa0babe (patch)
tree2d4288572b0938dcfc64edd39a4c1086402931a5 /dev-python/jupyter-client
parente28a6e6eb5373071be3a09aa457f0488d753c80c (diff)
gentoo auto-resync : 24:06:2023 - 13:27:08
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest2
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.3.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index a523124c7286..81d01f21fd6d 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_client-8.2.0.tar.gz 335567 BLAKE2B e02f8813d12ec8ba0e15291dad04cfaeeb98ea524050a10d142d74af203e43aa1c2e22e7fd7b071c05831b3dd644985a42e38f59fee65f4570e5eb88bbc9fbb1 SHA512 1337c4f2d93d9cd2ae5e3d8f30a8e4af69dad6e09c97e949d9300df0668be4da91134c73da06eb417c10ff2c09fd7beb28699e7a17502ceee3453cb9323b4363
+DIST jupyter_client-8.3.0.tar.gz 335973 BLAKE2B dd4b60994f5c2ba19d41f87dbbee1291e85595908e5b1fce77876d8164bc21bd65b257a65b333e2e3277fff66869d445fcd87c3c1a16166fa71da24d26b1e96e SHA512 2348cf67344cb9bbb9b020ef5570f5ca354c8acb00b9fb0d148b9419ec2efb922b1364ed3c2c2429ad66548af5dd90f232be1d56728ef09bd833312f13c07f77
EBUILD jupyter-client-8.2.0.ebuild 1301 BLAKE2B ab72062198275259d8c4027dd1752c55e9ea27035dd195310e8e09ea8f8eea45c575063006af7176fe91a05ae635b89ac33acb4385385062291c42e07ef3cd2a SHA512 b81e34798380f96ecd468e1e59e3ef106db15f51e729482f2d2dbb9b9f90dc14fa77fce16704979c4135e22f54f1f9632aa1661e0466ecc3cae8bf9e7e428f03
+EBUILD jupyter-client-8.3.0.ebuild 1310 BLAKE2B 2ded227ab10e5ffa4de5b75fc3b3ab09b9397082402e34eacec749b0df7633d469f10c042240e9399b5d0f382eac5619bc20aa6de8a0f3847f30ceb8b524acbe SHA512 0f73fbb6ce03aefc5ebc34b244246cdef58bc674204b3f3e92ad97ea8779ae4235ff1d8555f1c7f6f62ee67b98ccf8ef16517e4256da6228e8d462127dbeec76
MISC metadata.xml 844 BLAKE2B 8beea01f144f8e28b58b1bd4d0d2a32eda4b5e50e479c83ed940cd6894d581aa22418bc2733910465cb6980134c3a29b63a6e31f595d037b9492337285837ac6 SHA512 73f427cc561e728c6f941052a4b6f9c6ec5c9d6ba3bb601bc58313687dfc8d6ed3602e1fb2f7f0ea00aec4360c8c1200334675917d22092ed79585b117865ebd
diff --git a/dev-python/jupyter-client/jupyter-client-8.3.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.3.0.ebuild
new file mode 100644
index 000000000000..68af08dd73df
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)