summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
commit30114ae8ef07a32fea1e44a10b61f98c84142645 (patch)
tree1f5829906b913ee4637e04254cc50ffc1faab519 /dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild
parentaaa44376d7162304219748a3b6771d9a26fc80fe (diff)
gentoo auto-resync : 20:07:2023 - 13:07:51
Diffstat (limited to 'dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild')
-rw-r--r--dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild
new file mode 100644
index 000000000000..91c65f7bf3af
--- /dev/null
+++ b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="
+ https://github.com/jupyter-server/jupyter_ydoc/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ <dev-python/ypy-websocket-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst-parser dev-python/pydata-sphinx-theme