summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jupyter_client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest6
-rw-r--r--dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch39
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild40
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.3.ebuild38
-rw-r--r--dev-python/jupyter_client/metadata.xml17
5 files changed, 140 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
new file mode 100644
index 000000000000..ccc150627c34
--- /dev/null
+++ b/dev-python/jupyter_client/Manifest
@@ -0,0 +1,6 @@
+AUX jupyter_client-5.1.0-setuptools.patch 1062 BLAKE2B 1d01f2b7382d19f63c8bff813d6fbba21db25453e73366681d2b1a361f9842002ce7d5f535aca5e49e4073e36e708c28ce91aa59037daafe1b4da7627a47616e SHA512 b373c4bd3278484252430bf463d873249895aa6e5b041274352866d73de9fe3196dd64a73385aed8878b44a33e742e64623427d6a2d68706fcbdd70d4a539109
+DIST jupyter_client-5.1.0.tar.gz 265233 BLAKE2B 1f4533e1c6578e61b1a7591889805d5e324a3cd368cb3998131f2047056c87984ae26d83c9de0277aa6f19b61db4c4d9b39083b795e0891ef7d5394949b5fa44 SHA512 eca7adab1f8aae05743c341a257d4ca4338b0838cc3441939dda48229cdfa13b267bdc338b951bc4e6e139d03d26b40a1294140218f84ab800d211f7e0d8bfc7
+DIST jupyter_client-5.2.3.tar.gz 271787 BLAKE2B 36761e53050874c141c38f545f8f6fb53c144c30f686b3706594d124a65e410c205379b7ecbeed12f1520f0f568c7db3c802223f6fdb8f76407074beacc21918 SHA512 89b980ecc281bc1512e1fc4ba35862cc6e541f825ee07a1382d300c8088f24611225ab415d6a7c1e4209c47a74c113ec95f863e8fb0b33c6db9eb9c3521fc0ae
+EBUILD jupyter_client-5.1.0-r1.ebuild 1006 BLAKE2B fafe7632922c5b611495bac2ecc5bfc1c97bbe0fbaca3167ea3d806d39f7b4b48af638fb6f45b03c43bdd65ee0e2bbf47ec0f52cdd2d949e7d54eaef4c62e86e SHA512 07112f26abed3758fc0c793e6e237c6612ac64df90994e32decc5f9a48f999692c627dbefff010f50277ea3b0ad03f5dde57b7ad97a6dc867d579f6037fedb88
+EBUILD jupyter_client-5.2.3.ebuild 952 BLAKE2B f807026432d5ee8f7708f1a064b71e20e609c6fc8d7c2ff76d0f9fc4810f8f17b76c2c51c94f0cbc0412856ec7675d9e7158598cdbaa7f285a43faa55422f49f SHA512 04378d26190e45cf42f35a8fb11c24f9bab15c129535d27b09a89f79c44dc17d4c17f3b6276fda796d27f57c25d30e291c51ec88ce2a0efbda9481c249badbbf
+MISC metadata.xml 647 BLAKE2B 39c5be4c32d971bf1aacf3d384b370fdcaec2d77fc675a71065bd5b124559b174b3e4b7f1ef8bbdae4fd3f9b873822f4a2af68b1a9e5c05425c67cd67b226ccd SHA512 ffa9ecee1da3f5856daefeedbee972936ede17b2a828acd2ae1f80a82badc834afa2cdfef6f4a2dd70d29babdead8de8f5f60b888f0ff5e72b6b3993142177c5
diff --git a/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch b/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch
new file mode 100644
index 000000000000..ff7dcb0f3d4c
--- /dev/null
+++ b/dev-python/jupyter_client/files/jupyter_client-5.1.0-setuptools.patch
@@ -0,0 +1,39 @@
+From f9bd2643d42b3354b27e64368d8c15cad18101d2 Mon Sep 17 00:00:00 2001
+From: Philipp A <flying-sheep@web.de>
+Date: Tue, 8 Aug 2017 17:38:52 +0200
+Subject: [PATCH] Always use setuptools if availabe
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When running `python* setup.py install`, the `jupyter-run` script doesn’t get installed without this.
+---
+ setup.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 60fa17c..0831f7a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -70,6 +70,7 @@
+ ],
+ )
+
++# require setuptools for these cases
+ if 'develop' in sys.argv or any(a.startswith('bdist') for a in sys.argv):
+ import setuptools
+
+@@ -85,7 +86,12 @@
+ 'test': ['ipykernel', 'ipython', 'mock', 'pytest'],
+ }
+
+-if 'setuptools' in sys.modules:
++# always try to use setuptools if available
++try:
++ import setuptools
++except ImportError:
++ pass
++else:
+ setup_args.update(setuptools_args)
+ setup_args['entry_points'] = {
+ 'console_scripts': [
diff --git a/dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild b/dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild
new file mode 100644
index 000000000000..f1357b425b2c
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest --cov jupyter_client jupyter_client || die
+}
+
+PATCHES=( "${FILESDIR}"/${PN}-5.1.0-setuptools.patch )
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
new file mode 100644
index 000000000000..df80a23326e5
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest --cov jupyter_client jupyter_client || die
+}
diff --git a/dev-python/jupyter_client/metadata.xml b/dev-python/jupyter_client/metadata.xml
new file mode 100644
index 000000000000..53a086c17f50
--- /dev/null
+++ b/dev-python/jupyter_client/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Contains the reference implementation of the Jupyter protocol. It
+ also provides client and kernel management APIs for working with
+ kernels. It also provides the jupyter kernelspec entrypoint for
+ installing kernelspecs for use with Jupyter frontends.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter_client</remote-id>
+ </upstream>
+</pkgmetadata>