summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/jupyter_console/jupyter_console-6.4.4.ebuild')
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.4.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild b/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
new file mode 100644
index 000000000000..6f70ca03cce9
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest