summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/jupyter_core
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest2
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.9.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 036defc978dd..87bb539c1aa0 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_core-4.8.1.tar.gz 73579 BLAKE2B d5dcc89d948fa52f4a1b7c210585e9e5657004a431a4d177d7393d8283a9be86117e2c2452e4381399d1f479ae7b9ec4c5f891d09dd99c81768a64b69d8b182a SHA512 774612652537f46f486c0ae4157053463debcdc079d5e732865c729ef7fbab5f0d1b8da5d4e7cc1eda3a80250b43877d8f75889fa86330f951c61e3f8a7a29e2
+DIST jupyter_core-4.9.1.tar.gz 74787 BLAKE2B 3c902063c4d2819c8254eca87a64d922c3d1e408fc22e96d03765a8bb0fe644a9aafaccf3db106841becf307ffe47c9fcb723cad611833b5fcbe79e812ea2445 SHA512 3a176271e073448e3a15a69d51558486775abebec051e141594fe0d2859d9a0fc5cadbf6857764de6d1ec746f03d9d22419c91f97015d4ff6694626f455df773
EBUILD jupyter_core-4.8.1.ebuild 943 BLAKE2B c1b82bf4b305f0ca8f0061fec8aecb36cabb21e6a4945a1d6fafc121114351e81c31364054f97dc37c4b9e28e54de38380bb338b8e8951b21dcac67fb0159aed SHA512 2e6cda1840b973c5f82fb20a659a5c0b516c48ca641f1f972d14f3007b3591b8031f3231538d3867e53da7be2ef0c21e35f44fd98347418b46388393df640df9
+EBUILD jupyter_core-4.9.1.ebuild 1141 BLAKE2B 2eec7c150f8021ab36aa3c7a14399a7eb9844f3c4ad690a2c07950ac567b8c79dfb0f697126f006edd2b11d1076e445dee4c6cf1ae218238bb38c64c9a771589 SHA512 d313046283595eda456b97f9988d7d3a8ed63dc6c091993db8da15fc4be4629b392c5cac9d15229aff7ba3c3a96d768bc75ba5f5eb9d8ef74c2e33e76061a48f
MISC metadata.xml 759 BLAKE2B 4ef6a95640943d1b082bb65ae17515300089c6d78c0aa81410f4c7e57e1447787ad15373f314f8ea5c980459f4e5f74ee54edace2eb9421991e2425793040adc SHA512 d9769460a005d11961ebabc81636065aec545166820e923ab7abd58782e0832592a58611ccb4485164ef7c1c646812e8f608fafb9639525663732dec730542f5
diff --git a/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild
new file mode 100644
index 000000000000..a854289d7d62
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails if jupyter is not in system sitedir
+ # (PYTHONPATH is insufficient)
+ jupyter_core/tests/test_command.py::test_not_on_path
+ jupyter_core/tests/test_command.py::test_path_priority
+ # assert '/usr/local/share/jupyter' == '/usr/share/jupyter'
+ jupyter_core/tests/test_paths.py::test_jupyter_path_user_site
+ jupyter_core/tests/test_paths.py::test_jupyter_path_no_user_site
+ # TODO
+ jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
+)