summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/jupyter_core
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest4
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.6.1-r1.ebuild49
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.6.3.ebuild11
3 files changed, 8 insertions, 56 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 40288d54c967..1aa2048732dd 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,5 +1,3 @@
-DIST jupyter_core-4.6.1.tar.gz 66693 BLAKE2B f4338a015ac4b3e0a7cd2497a660bfca0deb96ffa2371fa9c72656f8a68b6f80fe5d494be79c8fdccbcb51f3d9122fd7d4b3e36864d38e7da1c5029c6b1aa24d SHA512 baf0c5db4f78a3cee83940ace80b48ba308c47eeafcf584120b8ba82768c15448fb789ec5b9ac8d541cbd1bfdd47a988f79130675c5943a67d3135d428b43cbe
DIST jupyter_core-4.6.3.tar.gz 67305 BLAKE2B 7c6a32bd8ce773b7bc4156eabf75597112716632179736b19be4b0e73eba7c5c67a0c9d2d141b952d72b68aff826227b0004a3bc9f3b286b68eb1375f2316bdb SHA512 3c7370c24a4cf53c9747e9e411852d207c0c7035809dab7cb018ccb53e19208df25ad4f728531e47f3a42c4d9694c3e1ed7b03133de23bcbdeb346c319f5f51f
-EBUILD jupyter_core-4.6.1-r1.ebuild 1077 BLAKE2B 811c274e81f9e8b5ffa2b13f9320879c3bcab774daba8c066f5d85bdf3e2ad58a6b165495ecc69c8db44f3e8bb7e86b28d80d8af0da1bfda98abde3841d2321d SHA512 19633ae6f33235f194379e8795a5af0602e4486917b4b9ceab6b170a45a23e640875961f0db0c1090a59b6436fa6b74565f48999e4c99599e0401e5e20e02892
-EBUILD jupyter_core-4.6.3.ebuild 823 BLAKE2B 7b497e6acabff002ccdf8d5b6926db693fc800ffb79d9a4114dce6ed438b4ffea1d5204880acfee7b020256e01653af550f72330b38b0285a657ea2919ee1bf8 SHA512 df825e9d1554647c86a087818df08b64091db134872bd78dc9df80bfc7f72af7912f9c29b747cae8a09c1cba22cdc218e0764e78cdc7e3aff8c431a60aeca656
+EBUILD jupyter_core-4.6.3.ebuild 873 BLAKE2B a9b154e32d11ed92a339b19ab9c0421693bf4fe8789f3b9dc4b8503b6024980ee3deb913f7d77ebecb1a9efce30fad6544baa1ba05dc5b39bf5ca69eb03e439c SHA512 015f86ab4e92bd94398378e102d0ad99b4a412b458b5b8dedd7de9948040e944819f996f615af7a334a48681bad1b36e9be7d642cf97e492acea3e236a97a6d5
MISC metadata.xml 733 BLAKE2B 1ac253b8e7dedbbb5291296d40d16280514f3a12fd3c905d32690cdefebb1844e60cd0ab516d04feb8a947f32a86ec4f2813c3edb2dc48638c734fb207adf825 SHA512 e180aa5a798b8e7fac09d83f7125058ece7e2ed9be722de31616f09408e46d87153c88345615af2d4691f155ea3999b4d83c4c6e21360068af469181ce13bef8
diff --git a/dev-python/jupyter_core/jupyter_core-4.6.1-r1.ebuild b/dev-python/jupyter_core/jupyter_core-4.6.1-r1.ebuild
deleted file mode 100644
index 6f686d287886..000000000000
--- a/dev-python/jupyter_core/jupyter_core-4.6.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Core common functionality of Jupyter projects"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
- test? ( >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- py.test jupyter_core || die
-}
diff --git a/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild b/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild
index 0891fa649da7..2a9d58b8c6d0 100644
--- a/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild
+++ b/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild
@@ -14,21 +14,24 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
BDEPEND="
- test? ( >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}] )"
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
distutils_enable_sphinx docs \
dev-python/sphinxcontrib-github-alt
distutils_enable_tests pytest
-src_prepare() {
+python_prepare_all() {
# rely on imports working without PYTHONPATH
sed -e 's:test_not_on_path:_&:' \
-e 's:test_path_priority:_&:' \
-i jupyter_core/tests/test_command.py || die
- distutils-r1_src_prepare
+ distutils-r1_python_prepare_all
}