summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jupyter_core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest3
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.4.0.ebuild56
-rw-r--r--dev-python/jupyter_core/metadata.xml17
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
new file mode 100644
index 000000000000..051ac7600c10
--- /dev/null
+++ b/dev-python/jupyter_core/Manifest
@@ -0,0 +1,3 @@
+DIST jupyter_core-4.4.0.tar.gz 63613 BLAKE2B 90b5d6c855786beff0ab780e7a894e1b24f6d6d1c26be6ae8da73e82a87f966f1155498c581314d37db845e293be7bc4d085e03991cdc7adfbba36409541cd5b SHA512 387f7f98f640b85ff0a24f11e1beae5a851d7eb3ba4a423be028940cb018c0d0ddf42ae8a1c397e3e4cafa560d3a5385b39bb8794448c7c010be7f0ddcba8a9e
+EBUILD jupyter_core-4.4.0.ebuild 1250 BLAKE2B a86cd8f580353ecb3ba5d61c6d3e92b4738d81deed38559eb9838976886715e63e1b891a2f868027d9660604f4c27f5776db874cfb0ce1a43f5f9ab7c3d4cfcb SHA512 5ebe15dfd489d4da3775247c5a96b952c35f89325c0cbc19bb9a67b01140fe5ceeaf0068ff3df94a0e09deb433e56ebb53db2514cbcf70241a85d94dd7d28bbf
+MISC metadata.xml 626 BLAKE2B d12f30014d60ed759b3d618b4fdb38bdf6d2d28738bc8c910d427d72e43cf792164cfa4811dd8c5717ecfc9d4705f6b4fce682be6d841b7185adc2942a62942f SHA512 bdac450a0bc297c925ea6431253eede78d61623feb30e1901f51a9e31722642741d5bc009162e09eb5b0fd9ca094e2eff54846b2612e99116239d764abb05533
diff --git a/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild b/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
new file mode 100644
index 000000000000..aaba36fb5686
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ !!<dev-python/jupyter-1.0.0-r1
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+# tests require installation of jupyter_core, bug #649538
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}
diff --git a/dev-python/jupyter_core/metadata.xml b/dev-python/jupyter_core/metadata.xml
new file mode 100644
index 000000000000..dd311505a57e
--- /dev/null
+++ b/dev-python/jupyter_core/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Core common functionality of Jupyter projects.
+ This package contains base application classes and configuration
+ inhertited by other projects. It doesn't do much on its own.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter_core</remote-id>
+ <remote-id type="github">jupyter/jupyter_core</remote-id>
+ </upstream>
+</pkgmetadata>