summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /dev-python/jupyter_core
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 7d75483a18eb..8c2b44a7842e 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_core-4.4.0.tar.gz 63613 BLAKE2B 90b5d6c855786beff0ab780e7a894e1b24f6d6d1c26be6ae8da73e82a87f966f1155498c581314d37db845e293be7bc4d085e03991cdc7adfbba36409541cd5b SHA512 387f7f98f640b85ff0a24f11e1beae5a851d7eb3ba4a423be028940cb018c0d0ddf42ae8a1c397e3e4cafa560d3a5385b39bb8794448c7c010be7f0ddcba8a9e
+EBUILD jupyter_core-4.4.0-r1.ebuild 1136 BLAKE2B 8245dc0b49886e67b24bd3fc27331f7c573e1df7262f9d6d7a3a12832945169f419b2a5ef41541b21f5f59990ec8949a91b2e65cc2585b24d09fdfe84472dc24 SHA512 bd5b4b2045f825018eae4e3c348dda4fea10ce0095aa898b91ea0a674a0e1d3a01965685a57b8fe16db2c9bca72692f1eb0559073f86aad4ff2a1f93c5899396
EBUILD jupyter_core-4.4.0.ebuild 1248 BLAKE2B 50bc482364a5d58575803b02d1695741a474767682273aac4c434e28a6797b741f61dcafcb447266bb996b8369ebcad8d07eb61d9b96545774a81152056f9347 SHA512 9843179ed6cfb9c83d1d52954795d5102c60717bd95afd52b35694d81cb82e092732444a464e18be4fdacf3069022019a25ffe5493271e57bab5a96ea1cc0017
MISC metadata.xml 626 BLAKE2B d12f30014d60ed759b3d618b4fdb38bdf6d2d28738bc8c910d427d72e43cf792164cfa4811dd8c5717ecfc9d4705f6b4fce682be6d841b7185adc2942a62942f SHA512 bdac450a0bc297c925ea6431253eede78d61623feb30e1901f51a9e31722642741d5bc009162e09eb5b0fd9ca094e2eff54846b2612e99116239d764abb05533
diff --git a/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..994c0dea0944
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+# tests require installation of jupyter_core, bug #649538
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}