summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/jupyter_packaging
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/jupyter_packaging')
-rw-r--r--dev-python/jupyter_packaging/Manifest4
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild46
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild2
3 files changed, 2 insertions, 50 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index c51786216c5b..9e87a6121d26 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1,5 +1,3 @@
-DIST jupyter_packaging-0.11.0.tar.gz 21847 BLAKE2B 61e637a0c47b117d42441343bf562f92d665abe0f5111588c91ef65b54e04d5c2878f13b9221128abf7e44070678cb878279a7227511c232d42161a159fd7f21 SHA512 35a5682ef99848f6f22b3cd2abeceaff81d575618ff670bcc664ca0bb77857b38c456a23c03787e9ca23a27901e5456c8417722163385da23efc9b85c15e015a
DIST jupyter_packaging-0.11.1.tar.gz 21715 BLAKE2B 68cde8becbe10710bc68912da43877db2704f59bbde5247bc2f27553b90cce47f16665326650e3cc2d1de8008d82ff22b8d485b0d2c782ecbb732e7bd059038c SHA512 1027e909222f9dbe9d317030fa07d7a71a91ef9de961681e6842e486e5e12cda03f998e0a7c2c0fc52e9c3ec3f527bf9643bc1640fa94b16b20b500fc69eff42
-EBUILD jupyter_packaging-0.11.0.ebuild 1061 BLAKE2B 962d4d9a91f13e93ce9414afea56f3f60b5228c95530ea7cb8343cf5aa8e81a7af444de41654060eace026cdeebd494cc6614b91af630b58839ec1530bf8b8c4 SHA512 3d52dedfd365813d15b06c355eae9be720924498c0ffffc2cc8c2c3eb813d7304815ea61848cccf0d5a593c004e9bff30371d6bc3c5071714ee7b347edfbe81f
-EBUILD jupyter_packaging-0.11.1.ebuild 1122 BLAKE2B 498b5b0f38bb7a2935ebc33681366ef0262f0a9fa4d3880999ad6f4a2d4ba9b8391b302be1f73140595f5a0a309c6b489904e64df366eedc1f2b5d78f47d247b SHA512 4ff17672c47abc9dde1406129b9812cf42fae7fcca665e9d54989d9c77da1cd2fbced1a1b89d64c217d39862ef570633d332530df19c692e169bff68db64ad2d
+EBUILD jupyter_packaging-0.11.1.ebuild 1114 BLAKE2B 7bfbf351121df796e515b80000d631735f1d4f1b7a210ce9c6e31a959176289b43f717d1c62c1dfdc0b07419363d5c506f008aed72186796527f28fa892d734f SHA512 5cf4c216e3d08c3c6f647f8c20014cefe2e4819d99bb0157f7799af32b84f26cdaac4c1dcb5fe87d9fdc2036713cf395d3eb42b8a21344c771b9947828bd5a74
MISC metadata.xml 436 BLAKE2B f17433d8ea516577cca652a0bb111cc9879ab5de87e056bb2cf28b3440858c92d8a942672f1d9e8be219c0aa7cbc255ccd603eef1920660366384b642c04430f SHA512 f7bd149e6c92e1164a5fc424a99bf44a1e15fcde8000171ad5d35828221ab38bedafb9460969bdde5151013f80a5197c1c1940d8434fe950104f149e9e8c449d
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild
deleted file mode 100644
index 6440233f72bb..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO: package "build"
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-
- # broken by Gentoo pip patch
- # TODO: retry when we finally make the patch less intrusive
- tests/test_datafiles_install.py
- tests/test_install.py
- )
-
- distutils_install_for_testing --via-venv
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild
index 38bcb9069529..abe5f246bfc9 100644
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]