summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/jupyterlab
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.6.1.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index fca286fd8ebd..6eacf06c6295 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-3.5.3.tar.gz 17114007 BLAKE2B 70d32721a2579331dd4e3481f7241f5e2c5aad6dac851f213de0ac1fc3b76667bea496bca5ea13ee562e9678d51ac45df91c5901d8d3b7dc839977d3d842e67d SHA512 fdacd34ab629da2b5c2eb23f11ba4d44d5b27872e1736850319bcabbe635d31cfa2891c1c5991b152a5c1d94221e3766a20fc91033f556d8e508374bc46d5fe2
+DIST jupyterlab-3.6.1.tar.gz 16845937 BLAKE2B 41c50a9ddefc0ec97c70843e15107d3e3cebfadea2ec148e4536407b0f1b202c2aeace794b02c7cb666c316434da614c1bfebab5e5fc7e654f62677bac6e1eb3 SHA512 9dc63162955c13721c97d620a60116cd75bf10eca9c8eab08ae35749bf2dfec84c55759a361ca1abab34c44d63eded95748cfea589aff98907045b483d778413
EBUILD jupyterlab-3.5.3.ebuild 2623 BLAKE2B 5a31b2cadf9398c5ba6c5273f25dcf0ce8921f9e28b2f3ff8e0eb9a335f779608d26f64860ec120da1aa85ce14a48c21f4cb37dc50e3780def58e40f026a1e79 SHA512 625279bc464242757e4481431bbcb9cd6ed6514333da1502256530a0557640ff7c4afc7ca5796a42fc2d7d282af50a1626a2c99884d3c0a0cd97f7483e8dcd25
+EBUILD jupyterlab-3.6.1.ebuild 2787 BLAKE2B c47731a19b8283da9ae6736f92a074a967a884e02da17c8f189c4a6ba68b06440b0f45f6441cd4b4168c0727f7b8f0d0e10671dde6f2aef99758191339cf25c2 SHA512 8386065320122c0a7172aa564c66273f406ef081082c9a309a538f1a3e57fd7d3c7fc40e3c80b340afd108ef54e7dac24702d0d83b118bb67adbf8555b4749f6
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.6.1.ebuild b/dev-python/jupyterlab/jupyterlab-3.6.1.ebuild
new file mode 100644
index 000000000000..7a468359518e
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.6.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_server-2.19[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_ydoc-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server_ydoc-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}