summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
commitf892e24578e434bbea68c4f1c9a8eef429461268 (patch)
tree5fc6072a72fd5ca8397e89183bad49896e6bf372 /dev-python/jupyterlab
parent0e7ef53ddcc33809bcb2644d3649617113b78ea3 (diff)
gentoo auto-resync : 23:09:2022 - 23:30:45
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.4.7.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index d5301bdb525c..6aa4ccb6b842 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.4.3.tar.gz 17074198 BLAKE2B 08a0aa4ddaeb6b48a742ef78e1b8cefb95fbf89ec077a1f3687c4498b7c4dbdd50e1773194c4f3c2e21d36a2010dcbcf2be0141df9383b2d05159bcb7f99ab9c SHA512 27c8d6b6636e14ea9a500764ea97b6ef16a1580728077264b662cc23b0e34ac0fd9eebe1eb5a79a64b18a2d93acc996553a6152fa135e2688b5eae21d184da57
DIST jupyterlab-3.4.5.tar.gz 17108960 BLAKE2B 83f4e99a1f98265df50857988dcd011862a0be4212abd8217cc330b3b536f5c7de2486f5c19e692c78eb8305f73c11a11772b510847ec25d756c81c828425ce3 SHA512 17428899b577a9e661ea755e3d6e2e3d640ca4ae28cd51e197520b9a388088e2a0d52a799f14b128d94f0c1ee2ec7580e309586c63e1d2e3b6019ae1075abc1c
+DIST jupyterlab-3.4.7.tar.gz 17111219 BLAKE2B 8e1246b56d75f2336ab46ca66f371dde275327a445563a8c41dcb528b58558c902776008f25b28e8a4fb299e9692c20b08c224f71304aa6f16143a757548814a SHA512 16a6e38fafbe3f8daa7f2e65b511e30b65800a1b21ee5e6360faae4cc1806472268297582f12a45d39d482ed5f25fc9c6874299e5e05efed5f50e8f2a3986c66
EBUILD jupyterlab-3.4.3.ebuild 2451 BLAKE2B ad9d7ec075273150ae2d72faa47e15b450554ea63f89b83557e738106f4be406601d94376f8bf3ab0a420c58a5637068a98dbfa7ac9220e252cfd99092e61542 SHA512 6f37117b68a7d48eaef436aa63efba4e876c32fb70900a6929e2dfee0a9cd5265ae3cf31bd70c17d514e18d30ff066b4055725715ccd2251e267b297b6f74594
EBUILD jupyterlab-3.4.5.ebuild 2493 BLAKE2B 15cd49601fb6d4a108c3c29f40cce25165ff52f4ae13ceab1c82538fd08c4a2856bb5129538584a22e40dc99d9fe59f5efbd4776ece0202739ec729abc4bbc26 SHA512 5e737b639a877f0c75d3701c0638c982bd8f2bd57d79c0fe04cd513abe75bf7e88c129bc76209974a9f91abd84ea7f2caeb2ccb79d909f48edcc5867fffb199b
+EBUILD jupyterlab-3.4.7.ebuild 2529 BLAKE2B 80bdea0077d41edadb683424e534d6b9e974ca5256bf01e539be641654741952a35f0e8a837cc8a4e3a2547b990187eb1687fd0f9c18b973668c9326714bb398 SHA512 8ea300df228cd21f6685aa51b8a1d53cd78fd0f282d3c32021931811846ee91b40ddd6014020601a48e235715930a1abbaf8777623dc0c0b948ae1c30f7340d3
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.4.7.ebuild b/dev-python/jupyterlab/jupyterlab-3.4.7.ebuild
new file mode 100644
index 000000000000..9d8ac6c3af51
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.4.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=jupyter
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}