summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
commitd4ce53f1e327bfbbc32e193e0f495b0e826c61e5 (patch)
treeeaee0038a45a76debf2097852b1fb076440f6cbf /dev-python/jwcrypto
parenta2210d6624510ad5825191a26603b73bbc096b98 (diff)
gentoo auto-resync : 27:12:2023 - 07:43:26
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest2
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.5.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index 1047efcb07a7..957a7f869776 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,3 +1,5 @@
DIST jwcrypto-1.5.0.gh.tar.gz 95669 BLAKE2B c8a408e3bdd929a939562eeebe59b33eb422fdf3251b8572b362a08286975220810bf7b2d0d937ef4f20c76ff133b5246f810a3cb7fa7caf685ecd03729ba5e0 SHA512 92c8c735dffe3664e93ead9a5764139f188d349b78c45d09ea9ede68b271f19f4cd16418f9184df49f2f9def16864624edc3d08bda30fd73fbf3daa2b12157a4
+DIST jwcrypto-1.5.1.gh.tar.gz 96563 BLAKE2B 13b39b27825031d4f30e1399bac085ba846551b5e50c49ae2a1ff31182e47a896ef9bfdd1705a40e59ddeb6850ba7bafd19ccf83d9f8177c47936e220df881db SHA512 fecb993a1157b6e689d3e845c8839f3178e32ab7fc920bf6b7328705293dae5e3d1424532b066f6dedd9c25a5cdeec91089ed4b83c4592cf6e1690419b5a5539
EBUILD jwcrypto-1.5.0.ebuild 845 BLAKE2B b6d4ec9cdc8a48c0ad30337cfe12fcc8ac3bdd53100f03adbd6e16ed1466750bec628fb1c1a87250a1f2c0949481b93963f4e97ae24059c2c48b6b66236c3459 SHA512 0f3083bd085cca20fc8cf2a5896acb86d779fa1a030df183518e48ae14b1487e8a1db7996e1f3867ae97d3bb89b19e51b3284ae4253fd0e70c1eeb93b48b333a
+EBUILD jwcrypto-1.5.1.ebuild 848 BLAKE2B 89b26fe10d873e4dd5b8451964dcc8863a7daedf209529a8658a6e0716548a7d591696d89abcfc9192f9704be2c84067f11546fc1e57ccaf490d4f4ce117c53d SHA512 65c3f64828b9ef9efa5ea8a72a37ab6f332e8a5563bdd10adefd380f1519f3d7fcc950fe41210a5e4092022ea0189a323eed3389a8f20aba82b74851755d785d
MISC metadata.xml 369 BLAKE2B c7868e0b20a2875964290642cddb457b71628e361f0e032875ac45f4405abeb76c8c53bcfe623c9a2e49ea6e184505503b4e43f34c456528ff3250aea5110b10 SHA512 a1fec6ac31bbb096e508b0ebd644aa8a96418e6972d852512d4b7702b67f241f858610235dbd68430c588d8b837c7a0866f333c8aab182e7cd01e10325031d34
diff --git a/dev-python/jwcrypto/jwcrypto-1.5.1.ebuild b/dev-python/jwcrypto/jwcrypto-1.5.1.ebuild
new file mode 100644
index 000000000000..e2992177e823
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-3.4[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}