summaryrefslogtreecommitdiff
path: root/dev-python/keyring/keyring-12.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
commit30c53e395853f5bfe805a1e429fcf26666eed8f8 (patch)
treea0670eaf9babda7b83503f7d36806a944bb49752 /dev-python/keyring/keyring-12.2.1.ebuild
parentd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (diff)
gentoo resync : 17.05.2018
Diffstat (limited to 'dev-python/keyring/keyring-12.2.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-12.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-12.2.1.ebuild b/dev-python/keyring/keyring-12.2.1.ebuild
new file mode 100644
index 000000000000..9b35a1c4afbe
--- /dev/null
+++ b/dev-python/keyring/keyring-12.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/collective-checkdocs[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+src_unpack() {
+ unpack $A
+ # This is an interactive test.
+ rm -f "${S}"/keyring/tests/backends/test_kwallet.py
+}
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}