summaryrefslogtreecommitdiff
path: root/dev-python/kiwisolver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /dev-python/kiwisolver
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/Manifest2
-rw-r--r--dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch30
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild44
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index 7ee3196657c0..1517009ab98b 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1,3 +1,5 @@
+AUX kiwisolver-1.4.4-pypy3-tests.patch 1001 BLAKE2B ebb5318a74bdd878c58234b0d71f4adb96e7180624588e24862005fb07cc834ce1da060d9ce543af5f5bc5408b3565f04b4bfd53eee9d1dd93cfd3c03908801a SHA512 2333bfdf39f65648a988a2abd7e3b1f02a24fea73dab3a155351035be8a3f3cad09a4bcdaaa4524ea7080b3774e1a573fd10e51107466765007c7914b02cf1bd
DIST kiwi-1.4.4.gh.tar.gz 91343 BLAKE2B a5e345509e7294eaf89e1361c035b3ef5d672d335682dbb426196d22876762b1f729cc728300f731a42afbfdf2828591f83cc53daf28e8d4c451a1b246b4800f SHA512 9a7ed487bb28f8c430543dc21ea59156078c129fd29b1382f1578368e72f312f4e813eb4501e4c9387647b42b085b93d4bd27d0e846f1396fa4ce68fd9e9ba5f
+EBUILD kiwisolver-1.4.4-r1.ebuild 948 BLAKE2B 630ee793fe56aa5295ce777d69692a31189afc4f9e027c811a84625eafa07b329adfa47f2c752abe28acdc59456eed3acc5689c0d52e5198e7e5999a8670ec9c SHA512 2a2321dae77d271f9d486cd9703997fc0804e0666929f8fbbf8c739ea4a4b94ee77d43722e3dcff25439d263ad522683c50d5a2684c34b153e2eed8585fedc88
EBUILD kiwisolver-1.4.4.ebuild 876 BLAKE2B c12505b827d2ad38b9f77cc8f1a20a40df4dad77a6514a0903908d0e0c812fadbe68b64cb8f25cfec91c8557030bf63e37dc1e0baa5b012a3f227adc5603752c SHA512 d6b367fc0d26a7ded41a4c897e0d7859e7b90bf2c68b5dce44e1a617995c8b47aea54462add04adee95ff7991af9d69a7afa4df7be1ae6393c4479f06d80b672
MISC metadata.xml 366 BLAKE2B d724248e9950219de4990e67822a16781e1a28f41d863fde04b3e1212b982a86819636a621b6e23089b76042ebbb23e0944a88ef9ab4c4abe62103f12197e5c2 SHA512 526fe3a81426edfc4c050631133799d948d1becb016319e954491090b9f3f6d410958db7027b5c2e2386b40c783f8c984b2588cda56e3ac58f3d2b1a5a8af0f0
diff --git a/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch b/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
new file mode 100644
index 000000000000..705855f02f61
--- /dev/null
+++ b/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
@@ -0,0 +1,30 @@
+Patch provided upstream as https://github.com/nucleic/kiwi/pull/158
+from issue created at https://github.com/nucleic/kiwi/issues/157
+
+commit ad1c62f046dc14c1e85e4e1c1b8e175eda08838e
+Author: Jérôme Carretero <cJ-kiwisolver@zougloub.eu>
+Date: Fri Feb 17 18:40:45 2023 -0500
+
+ py: tests: make tests run under PyPy
+
+diff --git a/py/tests/test_expression.py b/py/tests/test_expression.py
+index 671dd7f..6b5d8e5 100644
+--- a/py/tests/test_expression.py
++++ b/py/tests/test_expression.py
+@@ -8,6 +8,7 @@
+ import gc
+ import math
+ import operator
++import sys
+ from typing import Tuple
+
+ import pytest
+@@ -264,4 +265,7 @@ def test_expression_rich_compare_operations(op, symbol) -> None:
+ else:
+ with pytest.raises(TypeError) as excinfo:
+ op(e1, e2)
+- assert "kiwisolver.Expression" in excinfo.exconly()
++ if "PyPy" in sys.version:
++ assert "Expression" in excinfo.exconly()
++ else:
++ assert "kiwisolver.Expression" in excinfo.exconly()
diff --git a/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild b/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..67d18ec3f1e7
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=kiwi-${PV}
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="
+ https://github.com/nucleic/kiwi/
+ https://pypi.org/project/kiwisolver/
+"
+SRC_URI="
+ https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-python/cppy-1.2.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ >=dev-python/setuptools_scm-3.4.3[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.4-pypy3-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}