summaryrefslogtreecommitdiff
path: root/dev-python/kombu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
commit13b130894803eda558b74353eda3bf7504615b38 (patch)
treeeb6788b9eeef843120928d0df4cd2b5667aeccb3 /dev-python/kombu
parent5c9bbe083a12cfb9666fed4abe5bce219ff2f019 (diff)
gentoo auto-resync : 04:06:2023 - 09:34:05
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest2
-rw-r--r--dev-python/kombu/kombu-5.3.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index 1152a63ab02d..9e234972bef6 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,3 +1,5 @@
+DIST kombu-5.3.0.tar.gz 434097 BLAKE2B ef378014e4e52d83dc917f9dc6245111e94eddb70d9852da1add1b532ee733578db83c9ca5b4aa82771c443ecbd00e87384b7a373102e78aebcc6724ab1bf6b2 SHA512 688782cab692f0e18444289654e43f53b9a54627d5495933e9717b9676d689ddeb6de368081ea796df26727d4dfd5239ed7554736c13bfce7236e8d73f62b4a9
DIST kombu-5.3.0b3.tar.gz 436058 BLAKE2B d8470eea43a1d5f862d93e3b3608a3240b25cad6ccb342318a7bebda17e6ce818dce2889cb7af22fd77d2f6e69d1fdfa6926c77ba715c76dd40e973f3d9920dc SHA512 c330e1dd334810ed5fdeea234c49606aa8e43f84006703ff26d900f40ec7ce4920418bef3fd43abc8c792fb750499031191394475c45bfac50f7d29a6e30f5f8
+EBUILD kombu-5.3.0.ebuild 2189 BLAKE2B bd95c8289294dd30d616ac8f8a6f9fd1e73dc881253be5484eae0750e71081053339099760e036d7b35303e87e359964a09b03f62cbc4a07b238a39950f59752 SHA512 38830c7516f4cfdcf1042db3add897950e65060adad7e42dd6b61968cb29eb3c17a24fe3233999323ae91bc43dda7d89d56d700b9c924e4a3fb83342648ce976
EBUILD kombu-5.3.0_beta3.ebuild 2501 BLAKE2B 98fc3cc8811a27c570f1f74adc86d2126947c6aa2baed0406cf9334e417367dbed4f662ae848ee61b5e84d54a560ac9cba4f5a6ebd51de4214f0ac39de4f1cb1 SHA512 bbf3184dc093c41ca945dd9b1aa2e04bbf343c36cb2addd77163fc5d4ff7c561ef74767cdcd5d3233a6c7b0b20456ff6064a22a28735e4910d705e9831ac3f41
MISC metadata.xml 385 BLAKE2B 174062695338558e56601db5b6ced5eff3f6e22c1b840f1fe3d9046d6bc5f810fe1d3c73a3e7f009dae9129050dcb6824aca48ca86c006ecbd53f069884e60ef SHA512 eba10417212f73894b7bf749962c055c44ca10afbbff80f57e36f74edd016097c4854625a94e5a3522b3adf638c2c150e357f163f1617a79dd7fb54c234a1435
diff --git a/dev-python/kombu/kombu-5.3.0.ebuild b/dev-python/kombu/kombu-5.3.0.ebuild
new file mode 100644
index 000000000000..53ba0b0d0998
--- /dev/null
+++ b/dev-python/kombu/kombu-5.3.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="
+ https://github.com/celery/kombu/
+ https://pypi.org/project/kombu/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/py-amqp-5.1.1[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-6.0.0[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.22.2[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-celery
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ t/unit/transport/test_redis.py::test_Channel::test_connparams_health_check_interval_supported
+ )
+ local EPYTEST_IGNORE=(
+ # obsolete Pyro4
+ t/unit/transport/test_pyro.py
+ # unpackaged azure
+ t/unit/transport/test_azurestoragequeues.py
+ )
+
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
+ optfeature "Etcd backend" dev-python/python-etcd
+ optfeature "MongoDB backend" dev-python/pymongo
+ optfeature "Redis backend" dev-python/redis
+ optfeature "sqlalchemy backend" dev-python/sqlalchemy
+ optfeature "yaml backend" dev-python/pyyaml
+ optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
+ optfeature "brotli compression" "app-arch/brotli[python]"
+ optfeature "zstd compression" dev-python/zstandard
+}