summaryrefslogtreecommitdiff
path: root/dev-python/kombu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 16:11:27 +0100
commit260722f712fe06c113e7b13ad2e924ed14aaf0c4 (patch)
treea29845500e555a40458a70b7ed2896588134df2a /dev-python/kombu
parent0fde6d7108b1ee9fc6ad186eff4978faa255db20 (diff)
gentoo auto-resync : 31:08:2023 - 16:11:26
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest2
-rw-r--r--dev-python/kombu/kombu-5.3.2.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index 672bfdaebf0a..14cfc5eced58 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,3 +1,5 @@
DIST kombu-5.3.1.tar.gz 434284 BLAKE2B 8df6d441d1229fe188584a34cab6d40250dc119a189215ab8ae8ec6660dc25e85166f48786b6b4c2abd56b4eb9e6fdc15a92372078d6f412b728ce45be0a81e5 SHA512 608e70cc66dc19915fd2b40c3b908f3147f60a7c971be1d8bf04f3a18f78999a7a140073ecc9f38ec9aec49c1ef0a6f01fb5f2d27d68fc68bd64aade1924edfa
+DIST kombu-5.3.2.tar.gz 431102 BLAKE2B d617868a851382055acb44313f928aa2f1458700c29ee008f6eb7226010537bfbda6b306907e4901db1e51300abee969d574842a65f049f50507376103dbc670 SHA512 2960b3a2c8ef067d2cd82c8930ff00ffa8ce17d40a3b73597d274a289dec4ea24a2f250b19f4f02198be8cb5da067b9b45b7d07f4b15632ef96e9919bab739ea
EBUILD kombu-5.3.1.ebuild 2189 BLAKE2B bd95c8289294dd30d616ac8f8a6f9fd1e73dc881253be5484eae0750e71081053339099760e036d7b35303e87e359964a09b03f62cbc4a07b238a39950f59752 SHA512 38830c7516f4cfdcf1042db3add897950e65060adad7e42dd6b61968cb29eb3c17a24fe3233999323ae91bc43dda7d89d56d700b9c924e4a3fb83342648ce976
+EBUILD kombu-5.3.2.ebuild 2189 BLAKE2B bd95c8289294dd30d616ac8f8a6f9fd1e73dc881253be5484eae0750e71081053339099760e036d7b35303e87e359964a09b03f62cbc4a07b238a39950f59752 SHA512 38830c7516f4cfdcf1042db3add897950e65060adad7e42dd6b61968cb29eb3c17a24fe3233999323ae91bc43dda7d89d56d700b9c924e4a3fb83342648ce976
MISC metadata.xml 385 BLAKE2B 174062695338558e56601db5b6ced5eff3f6e22c1b840f1fe3d9046d6bc5f810fe1d3c73a3e7f009dae9129050dcb6824aca48ca86c006ecbd53f069884e60ef SHA512 eba10417212f73894b7bf749962c055c44ca10afbbff80f57e36f74edd016097c4854625a94e5a3522b3adf638c2c150e357f163f1617a79dd7fb54c234a1435
diff --git a/dev-python/kombu/kombu-5.3.2.ebuild b/dev-python/kombu/kombu-5.3.2.ebuild
new file mode 100644
index 000000000000..53ba0b0d0998
--- /dev/null
+++ b/dev-python/kombu/kombu-5.3.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="
+ https://github.com/celery/kombu/
+ https://pypi.org/project/kombu/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/py-amqp-5.1.1[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-6.0.0[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.22.2[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.2[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-celery
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ t/unit/transport/test_redis.py::test_Channel::test_connparams_health_check_interval_supported
+ )
+ local EPYTEST_IGNORE=(
+ # obsolete Pyro4
+ t/unit/transport/test_pyro.py
+ # unpackaged azure
+ t/unit/transport/test_azurestoragequeues.py
+ )
+
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
+ optfeature "Etcd backend" dev-python/python-etcd
+ optfeature "MongoDB backend" dev-python/pymongo
+ optfeature "Redis backend" dev-python/redis
+ optfeature "sqlalchemy backend" dev-python/sqlalchemy
+ optfeature "yaml backend" dev-python/pyyaml
+ optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
+ optfeature "brotli compression" "app-arch/brotli[python]"
+ optfeature "zstd compression" dev-python/zstandard
+}