summaryrefslogtreecommitdiff
path: root/dev-python/krb5/krb5-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
commit20325cfc3bd40d48d3c7034afaac4f5193d9c704 (patch)
treeb8e6ff7fc02271595e20f956b32cef56c41dafca /dev-python/krb5/krb5-0.5.1.ebuild
parent14a6858a7d8bc085420a1430b3a3f67885019f27 (diff)
gentoo auto-resync : 29:08:2023 - 10:04:54
Diffstat (limited to 'dev-python/krb5/krb5-0.5.1.ebuild')
-rw-r--r--dev-python/krb5/krb5-0.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/krb5/krb5-0.5.1.ebuild b/dev-python/krb5/krb5-0.5.1.ebuild
new file mode 100644
index 000000000000..82ce2069a68b
--- /dev/null
+++ b/dev-python/krb5/krb5-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Kerberos API bindings for Python"
+HOMEPAGE="
+ https://github.com/jborean93/pykrb5/
+ https://pypi.org/project/krb5/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/krb5
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/k5test[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest