summaryrefslogtreecommitdiff
path: root/dev-python/lark/lark-1.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /dev-python/lark/lark-1.1.7.ebuild
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'dev-python/lark/lark-1.1.7.ebuild')
-rw-r--r--dev-python/lark/lark-1.1.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/lark/lark-1.1.7.ebuild b/dev-python/lark/lark-1.1.7.ebuild
new file mode 100644
index 000000000000..f65a5584bcd8
--- /dev/null
+++ b/dev-python/lark/lark-1.1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="
+ https://github.com/lark-parser/lark/
+ https://pypi.org/project/lark/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require dev-python/js2py which is a really bad quality package
+ tests/test_nearley/test_nearley.py
+ )
+
+ if has "${EPYTHON}" pypy3 python3.{8,9}; then
+ EPYTEST_IGNORE+=(
+ # test using Python 3.10+ syntax
+ tests/test_pattern_matching.py
+ )
+ fi
+
+ epytest
+}