summaryrefslogtreecommitdiff
path: root/dev-python/lazr-delegates
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/lazr-delegates
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/lazr-delegates')
-rw-r--r--dev-python/lazr-delegates/Manifest4
-rw-r--r--dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild15
-rw-r--r--dev-python/lazr-delegates/metadata.xml1
3 files changed, 14 insertions, 6 deletions
diff --git a/dev-python/lazr-delegates/Manifest b/dev-python/lazr-delegates/Manifest
index 5fee7e2922a7..a3941f6fa216 100644
--- a/dev-python/lazr-delegates/Manifest
+++ b/dev-python/lazr-delegates/Manifest
@@ -1,3 +1,3 @@
DIST lazr-delegates-2.0.4.tar.gz 14168 BLAKE2B b9388a869e7f83e0bc30dc5a0cfb184a935db2b6272c2a9a93bb12d3db375114453a224703ef05b3f34232860a16fc087b7d398e94d164fbf77af61ba8abf102 SHA512 0c0b32a4fa4c132646d601870be0f0c1f1856aceb91bf979faa9a675fcbf94f76c7c6f548978a402842633cf4e53275c052cff7dfd776a4246691c067eabe501
-EBUILD lazr-delegates-2.0.4.ebuild 622 BLAKE2B 43ea6d6ae5590bf130df796d20289dabc604e233056095209b1150dc3e92e1ddc8294cbf90ee53a31f39ff7413d20d2960faa64c6de38da81d879f9cbefd265a SHA512 1c14184f14ebe5b1bb729fea3505cf4a2ccfd1982c7f3b1bcc42f01ad0dca3b493a05af59c5fa171e6604aca90adeedef0912f8d9461cbc8dab1c7cff47dd7c3
-MISC metadata.xml 410 BLAKE2B 299b41c39c31df7aaca8748d6adccbb348061e4fcfcfcd9ec9c9b14679c40ac530fa31eb7133b008d3fe2e979d7ec0a3f20867ca6d41c7288c4ec6a40a216148 SHA512 97b0932ff2b5e2b3f6e32a9af52d12c37fc737ef48b0ab453e858b7722d4c495807eb83a7acdcecbf129d2c9bf054504fb588fc661c2b625693be2759de24afb
+EBUILD lazr-delegates-2.0.4.ebuild 766 BLAKE2B 294f0d2d708cee0562c2b093433251f47155ea870406af4ded0e44a4e4cb95218f96b88633a7dc491182c18438a6a13c0fc77a27271bf34981fd97bcad4637d9 SHA512 b009a3334e05f1d8516ff7a65e738c6781ffbe197f486f5e26a34a80b9b50d2a683f4f3b8f1be2fc493d1d23419d5be0b146d6ff197a9fb66bbccf18bc6ed59e
+MISC metadata.xml 434 BLAKE2B 299603a878b11ada6e20c6372d94131c120534f47335359743d79c9519842ee274ecb32d8721ce6ba68c95c3cebbd9848e5a939510b1d3a501b5de763ebd77b9 SHA512 79196a3b0001b2fb4502fabf87e21544634f8d66e0d8174fcc7afc1f565fa92f1ee72a6b6f768477e395fdb33dd85ec83fe41c3f3058b70edfb0ecbe6529b4f0
diff --git a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
index c85bce4ae891..451b0f89c85a 100644
--- a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
+++ b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,13 +15,20 @@ HOMEPAGE="https://code.launchpad.net/lazr.delegates"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
-LICENSE="Apache-2.0"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/namespace-lazr[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/lazr-delegates/metadata.xml b/dev-python/lazr-delegates/metadata.xml
index ca82a0d0b4a9..d7cf82259ee4 100644
--- a/dev-python/lazr-delegates/metadata.xml
+++ b/dev-python/lazr-delegates/metadata.xml
@@ -8,6 +8,7 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">lazr.delegates</remote-id>
</upstream>