summaryrefslogtreecommitdiff
path: root/dev-python/libasyncns-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/libasyncns-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/libasyncns-python')
-rw-r--r--dev-python/libasyncns-python/Manifest4
-rw-r--r--dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch14
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild30
-rw-r--r--dev-python/libasyncns-python/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/libasyncns-python/Manifest b/dev-python/libasyncns-python/Manifest
new file mode 100644
index 000000000000..71f23be52f2f
--- /dev/null
+++ b/dev-python/libasyncns-python/Manifest
@@ -0,0 +1,4 @@
+AUX libasyncns-python-0.7.1-glibc-2.25.patch 509 BLAKE2B 413bcd6ce21af2db95dee5448907f708d0737861875514bcfdae033969f2a77608f2cb212c9f010f6e1d51583228571e3eb53bd96cab45fae812a1395a48d9ef SHA512 56270790454eddffc0a546a557f0360d637ce441e194b94d2a2af917ac42f25e9a7f376c739dfb93bdea1dfba5e6eb7a00a26507bf5c5814a77aa068a71b7521
+DIST libasyncns-python-0.7.1.tar.bz2 20276 BLAKE2B 80891e79c16b9e81f65d54107e2b8b715828fa005c05f0fc2e3b43ce96307bbf7ca3b13a233f975e8566a9ea8a644b8c138e8245243ddbdbcc722e3f74452e99 SHA512 ac8bd46cb842e40bc0f3720a789fe17a6488d80bf68f5f60b3093708d9e5f91d8b0082255a77d37c1814232d46a4c44c58abe971ddbe54f881d8e6a78937f489
+EBUILD libasyncns-python-0.7.1-r1.ebuild 705 BLAKE2B 539b6d10b645e761fb2aa1381aed0f7d5d93603c684a3b635bf4bed57a0f9de5d04188be4a97dbfecac2b9283102c0686d0bb54c151db5d25334c5ea66c6650c SHA512 774aa92a83a7afd7e0b19ef47da45d34298975d502d1437e1840704446a3aec0229350f82fcfc5faa726f50c6510b1b6f5d42633f3fdedeb04c38abec942c99b
+MISC metadata.xml 252 BLAKE2B c7a550712f19ecf95dc9bab7c6ce2510c3a0ed6f3abbd00dedb7044505bf4ac0081eda52712bc5883c631fac47ec74340207384dce1cdbb8312974b0140120a9 SHA512 ea1f58fbe07f5912fc69ec2182812dde68f0b5d38a03daeed9d22e0bbf4fdd6fdebad11674a0b51ed7d5b85abdacc64afebb8883dded1cbd0e9b767ebc9f283c
diff --git a/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch b/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch
new file mode 100644
index 000000000000..6ec84aa732b9
--- /dev/null
+++ b/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch
@@ -0,0 +1,14 @@
+https://sourceware.org/git/?p=glibc.git;a=patch;h=4f157746e0c713965d9143b52fef606312087c48
+
+diff --git a/libasyncns-python-0.7.1/libasyncns.c b/libasyncns-python-0.7.1/libasyncns.c
+index 99a73de..5e3da0b 100644
+--- a/libasyncns-python-0.7.1/libasyncns.c
++++ b/libasyncns-python-0.7.1/libasyncns.c
+@@ -134,7 +134,6 @@ PyMODINIT_FUNC initlibasyncns(void)
+ ADDNSCONST(ns_t_mailb);
+ ADDNSCONST(ns_t_maila);
+ ADDNSCONST(ns_t_any);
+- ADDNSCONST(ns_t_zxfr);
+ ADDNSCONST(ns_t_max);
+
+ ADDNSCONST(ns_c_invalid);
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..2c5ab37721e6
--- /dev/null
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libasyncns"
+HOMEPAGE="https://launchpad.net/libasyncns-python/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/libasyncns-0.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.1-glibc-2.25.patch" )
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+# Tests are network-dependent
diff --git a/dev-python/libasyncns-python/metadata.xml b/dev-python/libasyncns-python/metadata.xml
new file mode 100644
index 000000000000..da06078f5866
--- /dev/null
+++ b/dev-python/libasyncns-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="launchpad">libasyncns-python</remote-id>
+ </upstream>
+</pkgmetadata>