summaryrefslogtreecommitdiff
path: root/dev-python/libgnome-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/libgnome-python
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/libgnome-python')
-rw-r--r--dev-python/libgnome-python/Manifest5
-rw-r--r--dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild28
-rw-r--r--dev-python/libgnome-python/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libgnome-python/Manifest b/dev-python/libgnome-python/Manifest
new file mode 100644
index 000000000000..8659622e7b40
--- /dev/null
+++ b/dev-python/libgnome-python/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-python-2.28.1.tar.bz2 562220 SHA256 759ce9344cbf89cf7f8449d945822a0c9f317a494f56787782a901e4119b96d8 SHA512 632d91d416f8209c2bc8d576d1229069e00f2cfeedb3441a5f151e12973ed740c0bb26d18d5c16cfeeb64ca35933537997277450001cffd96d8d5077027d45f2 WHIRLPOOL cd4ea19fabd26c55866d8789628fdc3c834e73932381431216d65c5e9b42ad529e83f74d498951f07f060d3049f1739b6db99dbdbe34575eed469ceb23a51c5b
+EBUILD libgnome-python-2.28.1-r1.ebuild 860 SHA256 afebdbed36ffd3fa7fd34f88ad906911d1adaa7eaa96877e4b208329e8b1be67 SHA512 29d21d13d571407ecc76bc44cef6f13a723bb89e955c553fd41188c227ac99372c6ef2e79359d2665dc56ef8d0586697056c45f90c0b42a974fe695e6f93a0f4 WHIRLPOOL d41cdcef9267b8348909eb990b8bdd13280ce3448f80c29f52168f502111db327d5a8678b7252cb4dac36cabff1cebde9843f25ce707406995b951d9b98eb579
+MISC ChangeLog 2461 SHA256 ad5025c35a767e593615599684174f62c9f023f1b15b792992d95e65bdff3fd6 SHA512 e8ffa73452eceafa5eea929b136f00ac271a785ded3412977cfe76478a2740b83b8d4ab3b8478cf90a1aa26daf3a0104785b973d79ccaf9951fabf7356f6e0e0 WHIRLPOOL cb92a8685d867d00b4a2d94fb9f3fd031dccfe64014e6bf014e5e85a4f89cd5435d13d50535c96dd2b082442ede301b014fa31a8c08eeca785476b3cd43fbddf
+MISC ChangeLog-2015 6304 SHA256 7588861f0604121ec2221769084d4e1fa31064fdfeee685bbd2c6bd8d4791bd2 SHA512 07bfb8defd80e6ace3b948801dcbece607c23281cf210798bc8e5fdb543375449816620bc5095ad565d4dda161b5c78094a53bdba9dccd2940a5ab23a58a5bc1 WHIRLPOOL 46f1afe2b1e8c70b1add6a45166db574e5164bd797b1d649ab9db633522b86e0753e93def72351e63abb70a8b6b7fc13c73531e3b8056ffb3d00319a3bc2a1ae
+MISC metadata.xml 346 SHA256 e03340f54524c1be70afcd11b77ee1249143b59b69d9668673f9ed55d3002a9b SHA512 29ed867f32b1dc618689a6347b164ebe291bb061b90302dbfacd0c126a00bbcd7eaadcee11b075cb2c0fbf6e6534725a649a58e49dd1ea23cdd3f73af83ace77 WHIRLPOOL 97cde96f56111c4c355d88d8f353c1daea1012183c43b6c29ef6dd7f07bbf2b14a1477c5edaae58c73c604a05543e2a67e2ec51c439bf43e7a3ddcd577ee2606
diff --git a/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild b/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..0f3c3d1edc5d
--- /dev/null
+++ b/dev-python/libgnome-python/libgnome-python-2.28.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python"
+G_PY_BINDINGS=( gnome gnomeui )
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1
+
+DESCRIPTION="Python bindings for essential GNOME libraries"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples"
+
+RDEPEND=">=gnome-base/libgnome-2.24.1
+ >=gnome-base/libgnomeui-2.24.0
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/pyorbit-2.24.0[${PYTHON_USEDEP}]
+ >=dev-python/libbonobo-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/gnome-vfs-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/libgnomecanvas-python-${PV}[${PYTHON_USEDEP}]
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/. )
diff --git a/dev-python/libgnome-python/metadata.xml b/dev-python/libgnome-python/metadata.xml
new file mode 100644
index 000000000000..e4e250dd8100
--- /dev/null
+++ b/dev-python/libgnome-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>