summaryrefslogtreecommitdiff
path: root/dev-python/libsass-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/libsass-python
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/libsass-python')
-rw-r--r--dev-python/libsass-python/Manifest6
-rw-r--r--dev-python/libsass-python/files/libsass-0.20.0_rename_sassc.patch64
-rw-r--r--dev-python/libsass-python/libsass-python-0.21.0-r1.ebuild58
-rw-r--r--dev-python/libsass-python/libsass-python-0.22.0.ebuild57
-rw-r--r--dev-python/libsass-python/metadata.xml15
5 files changed, 200 insertions, 0 deletions
diff --git a/dev-python/libsass-python/Manifest b/dev-python/libsass-python/Manifest
new file mode 100644
index 000000000000..6787956656c3
--- /dev/null
+++ b/dev-python/libsass-python/Manifest
@@ -0,0 +1,6 @@
+AUX libsass-0.20.0_rename_sassc.patch 1710 BLAKE2B 410f1256dbe433d5836a0c7f94a30b0fbe174285408d5c3c0589a7f4f58d2417c9be37af6ae137031365450ad2bca51ebb2cd6083c625d95a33ac8c0eb3bc80e SHA512 3e30b6a5cc387aac526ca2159d5854b28090ab41d7d4b2512627cc1e5b392569b81c0b1c845d3311a9cd44c73a6ed109b2a06a9677cbe15a4a39c7ab0c7c4a6d
+DIST libsass-python-0.21.0.gh.tar.gz 55774 BLAKE2B 3c584ff3b6c09bc768554a3a4f7ef28ecea0726f59206da8540f9c1b4db74ab1235695074dd6b95db74f174066bb856c9854026525da82e7763f341920f0bd53 SHA512 d5b7a1bf0dc736a6a38e2e609f0a213306de31d5ad84cfdcd96f9ff72a1c38f15bad3cf25a1cec6dca5a9f3b00a8509afff2b4ea5e4db80e218e3ae603d55856
+DIST libsass-python-0.22.0.gh.tar.gz 55135 BLAKE2B 8495462fa8e6a68bf73ecdf68771c577bad1affa1121c1781dac41c912aae731df88c2b1d1a4ef363e50a98ff1b471e7c45562faa6f2425e8ec5f47f9cf76c6c SHA512 13914b60fe19fc70d197a948a2bc83f7646e4acaa45caed6df68bf2eb10e0a7ef811cdbbcc7a4338f9c1433cba8e316146c20072dc4ff34f51e094ead1bfdcd7
+EBUILD libsass-python-0.21.0-r1.ebuild 1563 BLAKE2B 00bef7766dd45363f3f5e6261521c346bebb2c7b569208ea268e62c26fef0b94eff2606fcc2b21f49b2ccc3c6baea430dae0025af8189fb4f8786a4ae025a33e SHA512 99468a2bb65170cf23b295b3ca531fa193e1738ce38be37521132c9fc39fa478556f881ed7a46a21c8116fd240e25001de461de42fe6783db377a80f60c7be1c
+EBUILD libsass-python-0.22.0.ebuild 1173 BLAKE2B e5f1b670b58b5e5f566d616eb38955aa3fed61b5861776ddd5fb0b3ef56f6103e4c94eafda023650ede35baa1a907175d1e2dc11a3697d1e3de128983b792b16 SHA512 7041ed8e6b7171f0cb60593249f88c5083d6e29f4ff45d1adcef0033f998d7aab38b139e60ad98d1847f9f7a3ddc0b56e938fd50ddfb401064615f9fe4fbfe00
+MISC metadata.xml 430 BLAKE2B 6d9f1d6a435110869d11d460136c6e1ede1119110111de1fd737caa92f52688a305645478542efc9a33f30f5534b55421ab63470db342a781b5f8f008048ba3f SHA512 b6dc1c8363dc915ad1ee1d6d1ec4f7599625648c0d75d4b159215069716a8e60f0efc72ad846cf59f7cf2736d083f4e37784c818d287b38e06b066b997c2f3ae
diff --git a/dev-python/libsass-python/files/libsass-0.20.0_rename_sassc.patch b/dev-python/libsass-python/files/libsass-0.20.0_rename_sassc.patch
new file mode 100644
index 000000000000..46efe8700328
--- /dev/null
+++ b/dev-python/libsass-python/files/libsass-0.20.0_rename_sassc.patch
@@ -0,0 +1,64 @@
+diff --git a/sassc.py b/sassc.py
+deleted file mode 100644
+index 2415342..0000000
+--- a/sassc.py
++++ /dev/null
+@@ -1,15 +0,0 @@
+-import warnings
+-
+-import pysassc
+-
+-
+-def main(*args, **kwargs):
+- warnings.warn(
+- 'The `sassc` entrypoint is deprecated, please use `pysassc`',
+- FutureWarning,
+- ),
+- return pysassc.main(*args, **kwargs)
+-
+-
+-if __name__ == '__main__':
+- exit(main())
+diff --git a/sasstests.py b/sasstests.py
+index 1f40a97..7547ab3 100644
+--- a/sasstests.py
++++ b/sasstests.py
+@@ -24,7 +24,6 @@ from werkzeug.wrappers import Response
+
+ import pysassc
+ import sass
+-import sassc
+ from sassutils._compat import collections_abc
+ from sassutils.builder import Manifest, build_directory
+ from sassutils.wsgi import SassMiddleware
+@@ -976,7 +975,7 @@ class SasscTestCase(BaseTestCase):
+
+ def test_sassc_stdout(self):
+ with pytest.warns(FutureWarning) as warninfo:
+- exit_code = sassc.main(
++ exit_code = pysassc.main(
+ ['sassc', 'test/a.scss'],
+ self.out, self.err,
+ )
+diff --git a/setup.py b/setup.py
+index e2a0c85..5905162 100644
+--- a/setup.py
++++ b/setup.py
+@@ -218,7 +218,7 @@ setup(
+ version=version(),
+ ext_modules=[sass_extension],
+ packages=['sassutils'],
+- py_modules=['pysassc', 'sass', 'sassc', 'sasstests'],
++ py_modules=['pysassc', 'sass', 'sasstests'],
+ package_data={
+ '': [
+ 'README.rst',
+@@ -239,8 +239,6 @@ setup(
+ ],
+ 'console_scripts': [
+ ['pysassc = pysassc:main'],
+- # TODO: remove `sassc` entry (#134)
+- ['sassc = sassc:main'],
+ ],
+ },
+ install_requires=['six'],
diff --git a/dev-python/libsass-python/libsass-python-0.21.0-r1.ebuild b/dev-python/libsass-python/libsass-python-0.21.0-r1.ebuild
new file mode 100644
index 000000000000..ec20d51c8ace
--- /dev/null
+++ b/dev-python/libsass-python/libsass-python-0.21.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+MY_P="libsass-python-${PV}"
+DESCRIPTION="A straightforward binding of libsass for Python"
+HOMEPAGE="https://github.com/sass/libsass-python/"
+SRC_URI="
+ https://github.com/sass/libsass-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=dev-libs/libsass-3.6.5"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )"
+
+# Remove sassc, in favour of pysassc, see: https://github.com/sass/libsass-python/issues/134
+# This avoids a file collision with dev-lang/sassc
+PATCHES=( "${FILESDIR}"/libsass-0.20.0_rename_sassc.patch )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ echo "${PV}" > .libsass-upstream-version || die
+ distutils-r1_src_prepare
+ export SYSTEM_SASS=1
+ # https://bugs.gentoo.org/730244
+ if tc-is-clang; then
+ sed -i -e 's/-std=gnu++0x//g' setup.py || die
+ fi
+}
+
+python_test() {
+ local deselect=(
+ # probably broken by removal of sassc
+ sasstests.py::SasscTestCase::test_sassc_stdout
+ # skip the pip tests because they need an internet connection
+ # not relevant for gentoo anyway
+ sasstests.py::DistutilsTestCase::test_build_sass
+ sasstests.py::DistutilsTestCase::test_output_style
+ )
+
+ epytest sasstests.py ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/libsass-python/libsass-python-0.22.0.ebuild b/dev-python/libsass-python/libsass-python-0.22.0.ebuild
new file mode 100644
index 000000000000..939120f5558e
--- /dev/null
+++ b/dev-python/libsass-python/libsass-python-0.22.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A straightforward binding of libsass for Python"
+HOMEPAGE="
+ https://github.com/sass/libsass-python/
+ https://pypi.org/project/libsass/
+"
+SRC_URI="
+ https://github.com/sass/libsass-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/libsass-3.6.5
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ echo "${PV}" > .libsass-upstream-version || die
+ distutils-r1_src_prepare
+ export SYSTEM_SASS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # probably broken by removal of sassc
+ sasstests.py::SasscTestCase::test_sassc_stdout
+ # skip the pip tests because they need an internet connection
+ # not relevant for gentoo anyway
+ sasstests.py::DistutilsTestCase::test_build_sass
+ sasstests.py::DistutilsTestCase::test_output_style
+ )
+
+ epytest sasstests.py
+}
diff --git a/dev-python/libsass-python/metadata.xml b/dev-python/libsass-python/metadata.xml
new file mode 100644
index 000000000000..0c2334d8a4a5
--- /dev/null
+++ b/dev-python/libsass-python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">libsass</remote-id>
+ </upstream>
+</pkgmetadata>