summaryrefslogtreecommitdiff
path: root/dev-python/libsass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-11 01:28:44 +0100
commitb46b9834b3fbf80b22ccc12e95f660512cd0fa75 (patch)
treef7eb18ccc89e078e2f175e5249fe0d4dfdb5b104 /dev-python/libsass
parent62f7102650b24618880e8e6f08fcb8fbd235025b (diff)
gentoo auto-resync : 11:07:2022 - 01:28:44
Diffstat (limited to 'dev-python/libsass')
-rw-r--r--dev-python/libsass/Manifest1
-rw-r--r--dev-python/libsass/libsass-0.21.0.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/libsass/Manifest b/dev-python/libsass/Manifest
index 6d6165ecd9c9..daefd8352439 100644
--- a/dev-python/libsass/Manifest
+++ b/dev-python/libsass/Manifest
@@ -1,5 +1,4 @@
AUX libsass-0.20.0_rename_sassc.patch 1710 BLAKE2B 410f1256dbe433d5836a0c7f94a30b0fbe174285408d5c3c0589a7f4f58d2417c9be37af6ae137031365450ad2bca51ebb2cd6083c625d95a33ac8c0eb3bc80e SHA512 3e30b6a5cc387aac526ca2159d5854b28090ab41d7d4b2512627cc1e5b392569b81c0b1c845d3311a9cd44c73a6ed109b2a06a9677cbe15a4a39c7ab0c7c4a6d
DIST libsass-python-0.21.0.gh.tar.gz 55774 BLAKE2B 3c584ff3b6c09bc768554a3a4f7ef28ecea0726f59206da8540f9c1b4db74ab1235695074dd6b95db74f174066bb856c9854026525da82e7763f341920f0bd53 SHA512 d5b7a1bf0dc736a6a38e2e609f0a213306de31d5ad84cfdcd96f9ff72a1c38f15bad3cf25a1cec6dca5a9f3b00a8509afff2b4ea5e4db80e218e3ae603d55856
EBUILD libsass-0.21.0-r1.ebuild 1561 BLAKE2B 173e244f5e492d3d3c4088a58bfbca988948b3e91bb7e787a952e0131ea26b5f987422f4c8343513e50f8f4902ee96e709a69f2eb409ea9331f184d390ff577f SHA512 9e60278ec5720c9dabe2e8f75a17f71db48bb669a22f13dda5d5c2d8f47a2b546dd080a38e5c058ed065143b49074401848ac142f83f9a4958867b5fd33b1c6f
-EBUILD libsass-0.21.0.ebuild 1527 BLAKE2B 1524db6af9b9d8f38626da41ae7f0362bb91d8514f368d920c4bb3dc1467f0771fb27cc704ed8c2167f90e020ff58f72d78ada6a7468824f52f5c7f56771c372 SHA512 4162ec08c68a798d489ea436e4ddf317d7d6ba8e75f89aa7fdc672cc5a097b6e688392de3a7b633d60556f7f28e2f6f8ef6db95c951c3233ad65c416b70da8fd
MISC metadata.xml 430 BLAKE2B 6d9f1d6a435110869d11d460136c6e1ede1119110111de1fd737caa92f52688a305645478542efc9a33f30f5534b55421ab63470db342a781b5f8f008048ba3f SHA512 b6dc1c8363dc915ad1ee1d6d1ec4f7599625648c0d75d4b159215069716a8e60f0efc72ad846cf59f7cf2736d083f4e37784c818d287b38e06b066b997c2f3ae
diff --git a/dev-python/libsass/libsass-0.21.0.ebuild b/dev-python/libsass/libsass-0.21.0.ebuild
deleted file mode 100644
index 42335f36cb91..000000000000
--- a/dev-python/libsass/libsass-0.21.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1 toolchain-funcs
-
-MY_P="libsass-python-${PV}"
-DESCRIPTION="A straightforward binding of libsass for Python"
-HOMEPAGE="https://github.com/sass/libsass-python/"
-SRC_URI="
- https://github.com/sass/libsass-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND=">=dev-libs/libsass-3.6.5"
-DEPEND=${RDEPEND}
-BDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- test? (
- dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )"
-
-# Remove sassc, in favour of pysassc, see: https://github.com/sass/libsass-python/issues/134
-# This avoids a file collision with dev-lang/sassc
-PATCHES=( "${FILESDIR}"/${PN}-0.20.0_rename_sassc.patch )
-
-distutils_enable_tests pytest
-
-src_prepare() {
- echo "${PV}" > .libsass-upstream-version || die
- distutils-r1_src_prepare
- export SYSTEM_SASS=1
- # https://bugs.gentoo.org/730244
- if tc-is-clang; then
- sed -i -e 's/-std=gnu++0x//g' setup.py || die
- fi
-}
-
-python_test() {
- local deselect=(
- # probably broken by removal of sassc
- sasstests.py::SasscTestCase::test_sassc_stdout
- # skip the pip tests because they need an internet connection
- # not relevant for gentoo anyway
- sasstests.py::DistutilsTestCase::test_build_sass
- sasstests.py::DistutilsTestCase::test_output_style
- )
-
- epytest sasstests.py ${deselect[@]/#/--deselect }
-}