summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 15:15:48 +0100
commit9d396115d657f4e18ffa2c1d073980d8e3d6710f (patch)
tree9f01ba3155b53183847eaf91e63b1e652ed6002f /dev-python/libtmux/libtmux-0.12.0.ebuild
parenta9b37934d0877c4249ea35c9e9c5b8cf3b836c9e (diff)
gentoo auto-resync : 01:08:2022 - 15:15:48
Diffstat (limited to 'dev-python/libtmux/libtmux-0.12.0.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.12.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.12.0.ebuild b/dev-python/libtmux/libtmux-0.12.0.ebuild
new file mode 100644
index 000000000000..38f4f726af96
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="
+ https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ distutils-r1_python_prepare_all
+}