summaryrefslogtreecommitdiff
path: root/dev-python/libtmux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /dev-python/libtmux
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest2
-rw-r--r--dev-python/libtmux/libtmux-0.9.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 1f42868158fa..fd91f371a521 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1,3 +1,5 @@
DIST libtmux-v0.8.5.tar.gz 222445 BLAKE2B 5af148555eb89c66bdc66f3f214967f7e901d9b86ea85e02a9fba64f2eb3559828519ba8120eaee5eb86ec75bee2e599a08384dd096de8dc0969129c58172c1e SHA512 d456725c3ca41a672ee5239bfb5f42a262674638d308fa141627995be8b8fe348bb8713b735eb05c5a3cc73f35fe3f6fac12024f6254c950a3048b2e07606363
+DIST libtmux-v0.9.0.tar.gz 215649 BLAKE2B fdf6f424ce8eead5f0f19cb53bfd438e9cd7b5326e57e676281f74cedac6e1bcd7cded27e4ef226d2fc3bc09bbb57ff0e63aaa7d901ab910b6a890275c7fe63d SHA512 d47078300614b2a286eab6063c9492baa115787b917d2fb2e4188032ce580f495f0e7f4a14383407c61063a77d640092d117ba43974524f18da024dfc687c8a5
EBUILD libtmux-0.8.5.ebuild 897 BLAKE2B c85a8896ceef6b29baa93f6a406b6256b635b76c0a3123ed5782a6f2224a2a238a35bc90284fa6bffdf8e80fc92317c60ab4e6cb2ecfbabd6beeac2f1fdcd20e SHA512 296c8a852ef822604240edabb47f029867817f86d6d4f5f0b6046f8edbf9ba9788354864ee921046621681b5942ee371372d1fbd1cd5632ef52459d68035db4f
+EBUILD libtmux-0.9.0.ebuild 977 BLAKE2B cb7b24f0ece2c8d5f7814db0767d54e1fab90789c92a3fa34a020260cef26bf31aaaf51d20480edb188b2d187df2cfdff953b58b81326ce2ebc6173d73379878 SHA512 3767d7932a928e80b6088e58f52e7f14e6810e0b76943b28f65eeac018377d3b9c93c17cb9454f5c3297253a8e79f494a90f37a71d02dac4c28988b3ee3a4c3c
MISC metadata.xml 343 BLAKE2B 66c3f5a64242dfaf69b7828e9e90de5eb93bd1d95a008cd41b748fe768280678f7be3d9e930690be44fa7f639de589074f056ec4d39bb882fdfff9dbc76f3558 SHA512 897920796a56516a2cd2455e689b364cf92080b65a3f7c0f8b40b56e2f4c1c693a29cd6eca755ff51e3b1b57a8be1136a5648f1ed8857933d6e7e20628eece5e
diff --git a/dev-python/libtmux/libtmux-0.9.0.ebuild b/dev-python/libtmux/libtmux-0.9.0.ebuild
new file mode 100644
index 000000000000..b252f9c9bdae
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=app-misc/tmux-3.0a"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_{7..9})
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ distutils-r1_python_prepare_all
+}