summaryrefslogtreecommitdiff
path: root/dev-python/libtmux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/libtmux
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest3
-rw-r--r--dev-python/libtmux/libtmux-0.8.1.ebuild31
-rw-r--r--dev-python/libtmux/metadata.xml8
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
new file mode 100644
index 000000000000..228a5ed8659f
--- /dev/null
+++ b/dev-python/libtmux/Manifest
@@ -0,0 +1,3 @@
+DIST libtmux-0.8.1.tar.gz 37696 BLAKE2B 48f780ed2c1243c752d35d58f1a7eee4d59297047abcfb0c02c8c9206ad2f8c7df9c2968935e30457dd14be8a9110b9cb1e3b7daf4d5df43e3533e400cd8b21c SHA512 c45e8c761fb9a6b827feff96d4bb263fb0419509a1bd450ac4038d7ad0b96b3047f0d6f3c7bbaa16686918ecfe3c8d189b99982574e4056abf5a491b20e0e7f1
+EBUILD libtmux-0.8.1.ebuild 676 BLAKE2B 3f7f42fa2305111aa785cdef6ef2690122369ef09d58efe57b797e271b5a9cf0390a6d276b69f25ae214355d94f12a6d96a7fdeb2370522d383c8e156980a265 SHA512 080858d629bd06dec3703d65b6e07f36ce9a379ab9d2263883c1794a858ff4a3c2e891e021a52cdb559961c01400743f571b4120c8afc6b6d5e0c3bc50dc7952
+MISC metadata.xml 255 BLAKE2B 2bb3830b8cec850703f7912f4c22f5b0abeabeed0715222bc56141779d02160773cfd0f85417c553c1cd8f2738bfeb78c56dffb8e648e572019319657646d1ba SHA512 522158915afe67937f81ba572a918a2de8ca1f8591e097da56799c97870d7c44756c1acd8224d63bd3375c2b9ebc0e1ce50816899117948a48065a27804883bf
diff --git a/dev-python/libtmux/libtmux-0.8.1.ebuild b/dev-python/libtmux/libtmux-0.8.1.ebuild
new file mode 100644
index 000000000000..517f2c71e586
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}
+ test? (
+ >=dev-python/pytest-4.3.1[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+RDEPEND="app-misc/tmux"
+
+# tests aren't included in the dist tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/libtmux/metadata.xml b/dev-python/libtmux/metadata.xml
new file mode 100644
index 000000000000..56cae167d372
--- /dev/null
+++ b/dev-python/libtmux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>