summaryrefslogtreecommitdiff
path: root/dev-python/libvirt-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /dev-python/libvirt-python
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest2
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.3.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 71a14498544b..4d3ce384382e 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,6 +1,8 @@
DIST libvirt-python-4.1.0.tar.gz 186312 BLAKE2B 45ba81eb738e72e2561ab597c5cc395ae2260c7d93575391d2ce14622faf706052ea5d83adf6ca6a52c35cda4a9e80348f163f48ba318f5d0056b26a33961d25 SHA512 533c46c6827b0c3397713b39a7c6486e1bad40571907aa48da7818ad15569d4e01e33ffc787beb9486fc84b361985aa1d30ea474555d55494143f71dfea26947
DIST libvirt-python-4.2.0.tar.gz 186496 BLAKE2B a4d556a0159c338f2a3a5fc8e6072b084aab427170b66f00dce5b8c4649bfd7d821e02846de906584a454acf2f1db34718a2f48110cf5c8faf6594a72b6e8f2b SHA512 4c06d7de470ff22ee5983598e66d26a3e850998311c8061952f9f6b5be0a7a0f437e2b214d3d66bf465acec9afb925dfb6dd0cd756ed78e818d19e15e7cfdf6a
+DIST libvirt-python-4.3.0.tar.gz 187111 BLAKE2B 7266ca1b5836429e13a03dab0e2f5085521c72e2d6952d7a9de514eace286477ad7b237c5d70f86fac49ab2201c8724149af72d4c1f688ac8736257045babc6f SHA512 4b2b4a2590e968ff4401d8429319c94b1b9c08a40b089f461af5a4912acf2c504f60652c80b161c253c00e41d22c100c2e180159e45d84c352c59dca69172cfc
EBUILD libvirt-python-4.1.0.ebuild 971 BLAKE2B caf77d87ce352223c8c169ed840374c61109b1737c1a7d670d8246bf7d74b5577a90568769d1abfa50511293d3c4f3c3edc6b4497e4df230394adc5267031c5c SHA512 15c3b85fe89d593d0e4438fdc537bde2143fea5bae099293241ff78974df6141a730d6f9e3735593ac7b8a91301efd599a42d07699b81e166fec45e89a265690
EBUILD libvirt-python-4.2.0.ebuild 964 BLAKE2B 28b03bf2c512a12d539b1e1cb15793821dd1763ff142e12bb6fece94b41f8bb29f1897c2c88479356f5de8d44ef81c3237730a1736ddfc4e3c243140c523f685 SHA512 dd0e54bab5b1a3cdd5dac84c1b9fe7f0191c9a1b388b0a2495992c798553ef10830b2a168906f9fadbab1a39e8749f486085b535fae981209214080205f2be42
+EBUILD libvirt-python-4.3.0.ebuild 964 BLAKE2B 28b03bf2c512a12d539b1e1cb15793821dd1763ff142e12bb6fece94b41f8bb29f1897c2c88479356f5de8d44ef81c3237730a1736ddfc4e3c243140c523f685 SHA512 dd0e54bab5b1a3cdd5dac84c1b9fe7f0191c9a1b388b0a2495992c798553ef10830b2a168906f9fadbab1a39e8749f486085b535fae981209214080205f2be42
EBUILD libvirt-python-9999.ebuild 969 BLAKE2B 7eef27fd34c2368a8fadbae51f5e76acac23f72c66935dc2fdc0c19e3ab7dbb1b05e4a87ff90a72e4972408bfb63c15efbeb2b46d31951387eb975567bd26aa3 SHA512 4de4f941bef900a032f6d3473a868070eb087dcfaf332e53bada1adb9222cab13e388caad11c6dddf2042aa4c4e266ba12150ab4652c9ef1c4b2bf4466bf5c37
MISC metadata.xml 518 BLAKE2B ac9993d622790a5cec52f737de0494b7ac6a5a6e17e66ccad8e4862257ba8926d688fa4b6e68cd96ea5a4f2d35825204219fd79bc5917d05a6f39787f80bc1df SHA512 243b815c70c65046d672bc2b4a05d67f61c6e70dc6677ef7e8b76783979d801793f8d864a33ed9c64072c4fa30786d4455c82c82fa37933dac0b0efac2264083
diff --git a/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild
new file mode 100644
index 000000000000..172f3dc38862
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}