summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-15.0.4.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
commit145ac95c683ecda55a9b2cafc84dced2e9c29e03 (patch)
tree3a7aac2c145afe328a1c610a9ee6d7f5b9fd271d /dev-python/lit/lit-15.0.4.9999.ebuild
parentbb17db5f98333b3c74b4194d1c1136144f693add (diff)
gentoo auto-resync : 24:10:2022 - 15:52:09
Diffstat (limited to 'dev-python/lit/lit-15.0.4.9999.ebuild')
-rw-r--r--dev-python/lit/lit-15.0.4.9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-15.0.4.9999.ebuild b/dev-python/lit/lit-15.0.4.9999.ebuild
new file mode 100644
index 000000000000..8ace6ca8b915
--- /dev/null
+++ b/dev-python/lit/lit-15.0.4.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}