summaryrefslogtreecommitdiff
path: root/dev-python/llfuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/llfuse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest6
-rw-r--r--dev-python/llfuse/files/llfuse-1.3-cflags.patch19
-rw-r--r--dev-python/llfuse/llfuse-1.3.2.ebuild42
-rw-r--r--dev-python/llfuse/llfuse-1.3.4.ebuild41
-rw-r--r--dev-python/llfuse/metadata.xml11
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
new file mode 100644
index 000000000000..1618f781749c
--- /dev/null
+++ b/dev-python/llfuse/Manifest
@@ -0,0 +1,6 @@
+AUX llfuse-1.3-cflags.patch 752 BLAKE2B aff689d4ddd5b5e5cc977595891c68b4e4b5876d0faf5cd243be942961abec618f861d835fa501585c04902a4be1491854d8a80c32442b4125cfdf8c29984444 SHA512 e0751e90fa89fe7fff6844b5be3cd8b55cbe4c62fb3341643a9049ff54c2e8bccc439ce444822b9d0858c83a3cd12dbede5253f9a9e6544ef26747a19f8f233a
+DIST llfuse-1.3.2.tar.bz2 348035 BLAKE2B d3a3219c8d7462f448486488971842362b6ade8fcf6804d725db30b0e91d3f240ec9443705cb67caf3e6beae8a174f323465695dddd132210e3606aef6dd861d SHA512 f065818134b12dd128574836bc7d339404d9b7d9236b535da709378e9206b17cb2accd97fc0b658f39a93efe126a7c3064f7901468231f63f8398a3e053498cf
+DIST llfuse-1.3.4.tar.bz2 364400 BLAKE2B 726a42381b84fc57e3e54d519bc1a105056cc8cf5d1c586ea12b1798db493254df7088f1060ffda0d89887c2b7db2046825e4f044953153e7978891f72032457 SHA512 6bda4534f660c42e6740093be0a2c308367f5915a0144d44c390b4f6b197efafb48bc28f7f8d1735defe470e37637bd6688690e26ec3d0c01cb7c197e443f6e6
+EBUILD llfuse-1.3.2.ebuild 1031 BLAKE2B 0e6725a78cfbf939654bbb986ab2537d2d06fdbac00f205fb1095f82515c2fc0c05d5f8c04394ba39c4af7f8ed9a36c0a5fc5e6ac76ab00eea55bcfea7dd7e2b SHA512 6344c4a14c45c177a44ad5c3a48aec2a7c206d774e3b4008f25dba53678e9bc708e9edff2ab3b9aac8d070db9441d1d5cee5d730655a9842b42ca99b9aac00c7
+EBUILD llfuse-1.3.4.ebuild 986 BLAKE2B 500242c0ab46b5565498b0325c37a1790e61af47e3b6aabb57ff3039699abdbe3161c058c7c6ff80a710381f8a93bb5f8736291b36ffe3a105fdcc49227898d6 SHA512 be44aef73335b5caec9ef0386358c2e0e3593c3d65afc44bb78b7a6ff3912ff0893e8cd9a7905e41b8f22577c9eb2971a9633dd42a17312c16e0c7ef52d85dcb
+MISC metadata.xml 309 BLAKE2B 35b86dac2f17820c91bccad58f8c0caa57d8b8ec9b549cca330ec285271cd8cbcae173b7d68fdfc7eb7b99f051eadd37b5ed1053f20e57021e6a51ad460f867a SHA512 31061d2419abdc0ded07625ee0a21bc77162b15db90e2559ab9ce71e8a3aed1c866de5aebd8b1b24f566b79a85a45bec4c941542d268daf9df65bdb711d59342
diff --git a/dev-python/llfuse/files/llfuse-1.3-cflags.patch b/dev-python/llfuse/files/llfuse-1.3-cflags.patch
new file mode 100644
index 000000000000..42e4eef82a02
--- /dev/null
+++ b/dev-python/llfuse/files/llfuse-1.3-cflags.patch
@@ -0,0 +1,19 @@
+Build fails under pypy(3) when enabling these flags.
+
+--- llfuse-1.3/setup.py
++++ llfuse-1.3/setup.py
+@@ -84,12 +84,12 @@
+ compile_args.append('-Wno-unused-parameter')
+
+ # Value-changing conversions should always be explicit.
+- compile_args.append('-Werror=conversion')
++ # compile_args.append('-Werror=conversion')
+
+ # Note that (i > -1) is false if i is unsigned (-1 will be converted to
+ # a large positive value). We certainly don't want to do this by
+ # accident.
+- compile_args.append('-Werror=sign-compare')
++ # compile_args.append('-Werror=sign-compare')
+
+ # Enable all fatal warnings only when compiling from Mercurial tip.
+ # (otherwise we break forward compatibility because compilation with newer
diff --git a/dev-python/llfuse/llfuse-1.3.2.ebuild b/dev-python/llfuse/llfuse-1.3.2.ebuild
new file mode 100644
index 000000000000..31e87a88930b
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0:0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/attr
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3-cflags.patch )
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/llfuse/llfuse-1.3.4.ebuild b/dev-python/llfuse/llfuse-1.3.4.ebuild
new file mode 100644
index 000000000000..106a17eff394
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.3.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0:0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/attr
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3-cflags.patch )
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/llfuse/metadata.xml b/dev-python/llfuse/metadata.xml
new file mode 100644
index 000000000000..9460e17f2acd
--- /dev/null
+++ b/dev-python/llfuse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">llfuse</remote-id>
+ </upstream>
+</pkgmetadata>