summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/llvmlite
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest3
-rw-r--r--dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch32
-rw-r--r--dev-python/llvmlite/llvmlite-0.33.0.ebuild66
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index a0de91553baf..e2081488e19a 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,6 +1,3 @@
-AUX llvmlite-0.33.0-llvm-10.patch 1140 BLAKE2B 175f1a5596e7ce1f20e7e89978066cea345af361eb0db9413bf105e657128d45fca1c170aa516d74376f4aa4dcff9699d5c48120378f239c61ee59cc29a61713 SHA512 666e2dd798d2598139a72560ae0a63a397dfb643645c3eb3d92f0d2dfbd3030484b7e59e3aec8fa071d314b974f8d54b1a174473c3fbf4534d69492331ebd456
-DIST llvmlite-0.33.0.gh.tar.gz 196450 BLAKE2B 3b1842b53eabf5cbc30aa642e12d214bd0cf8473f39873ad2b83de830a251ceac20281e2c8a528fff4623faeebf1583ab539cac74587bcb49ccaac22c922a16f SHA512 50b35db717ccc9d78cb7faa2e0b43cf4a622c5fca662ceb18c14163a26456fb79ed844db9a50e4566a2ea5c26089a419ca130d16b18a2486d4137e8a410ee3b9
DIST llvmlite-0.34.0.gh.tar.gz 210438 BLAKE2B 832ec28047a51b2874a0de5885445b9d77942a70f86620dfb0b25ff0b17395b6009d31d5e9f27ddf02c19ae97bd5b325fc49227fdc0499a9f5fa3bde44e6b564 SHA512 5540df4ebad835e294c00cc09ab1230a530566f563f751f890752f6e22f7b2a04aedcbb53dbbb8e323198d05c80bc9699b593d919eaf1af60fa6f94ff6f50bb1
-EBUILD llvmlite-0.33.0.ebuild 1607 BLAKE2B ab085835ea02ccc0729079da07089428625f9e5a196886406facf49cd7cf80614ce71acc9e9b7ee11e24d8518b1adb4250561fd84d3e4742ce93e4ccaf79aa54 SHA512 d24723298c85bf17f218595e0515b168de3157693370a00083cb57473202677ca87909013c5e9274d710d14c0f3473c3ae6de96f404f5a219dbc308efdc3af8a
EBUILD llvmlite-0.34.0.ebuild 1354 BLAKE2B 0479672c088a56c7f27bb2a7cd615448d456f5db3e042ce608ec1f12dc69b4fbcb95db79efc8783c9333d6e52672ba7abecfc3b68accc5bd15618003206fb660 SHA512 97248a6a08962e07dd5dce71bf52eb75c76630d634d9e423ed02b1bd6dc178b24bd38fc5f1436edb563a9475555218f39cb84bf086ec82457e5403c6714903b6
MISC metadata.xml 792 BLAKE2B 8247c0ac546df47bc70b8e525d776dd391fa553d75d7bb0507986ac2f7efe1d023db7259f8938c13b383ef719a10acb3e1357bca4dc398a42b68ba756c0c351a SHA512 8dab7bc4b6d33f9a3c458dde08e07fe22680238185e8f144ada7ce7374ecb3fbd38149f67d2a11cba7a816384c556edf618e45ec331e6054b97aee60c529a35a
diff --git a/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch b/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch
deleted file mode 100644
index b6c4242e4459..000000000000
--- a/dev-python/llvmlite/files/llvmlite-0.33.0-llvm-10.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 87a2de4b22e141d37b796dce77a6daef243145eb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 11 Jun 2020 09:22:32 +0200
-Subject: [PATCH] Use std::make_unique on LLVM 10
-
-LLVM 10 removes llvm::make_unique in favor of std::make_unique.
-However, this requires C++14 and is therefore unsuitable for LLVM 9
-that forces -std=c++11. Update the code to use both conditionally.
-This fixes all issues with LLVM 10.
----
- ffi/linker.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/ffi/linker.cpp b/ffi/linker.cpp
-index 57bb80b..585b261 100644
---- a/ffi/linker.cpp
-+++ b/ffi/linker.cpp
-@@ -42,7 +42,11 @@ LLVMPY_LinkModules(LLVMModuleRef Dest, LLVMModuleRef Src, const char **Err)
- auto OldDiagnosticHandler = Ctx.getDiagnosticHandler();
-
- // set the handler to a new one
-+#if LLVM_VERSION_MAJOR >= 10
-+ Ctx.setDiagnosticHandler(std::make_unique<ReportNotAbortDiagnosticHandler>(errstream));
-+#else
- Ctx.setDiagnosticHandler(llvm::make_unique<ReportNotAbortDiagnosticHandler>(errstream));
-+#endif
-
- // link
- bool failed = LLVMLinkModules2(Dest, Src);
---
-2.27.0
-
diff --git a/dev-python/llvmlite/llvmlite-0.33.0.ebuild b/dev-python/llvmlite/llvmlite-0.33.0.ebuild
deleted file mode 100644
index 89ee4202cbb9..000000000000
--- a/dev-python/llvmlite/llvmlite-0.33.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S=${WORKDIR}/${P/_/}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=9
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # test_version hardcodes permitted versions
- # test_parse* relies on exact error message
- sed -e 's:test_version:_&:' \
- -e 's:test_parse_bitcode_error:_&:' \
- -i llvmlite/tests/test_binding.py || die
-
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}