summaryrefslogtreecommitdiff
path: root/dev-python/lmdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/lmdb
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/lmdb')
-rw-r--r--dev-python/lmdb/Manifest4
-rw-r--r--dev-python/lmdb/lmdb-1.2.0-r1.ebuild39
-rw-r--r--dev-python/lmdb/lmdb-1.2.1.ebuild39
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/lmdb/Manifest b/dev-python/lmdb/Manifest
index edc950a05aed..694e7f9ee7d6 100644
--- a/dev-python/lmdb/Manifest
+++ b/dev-python/lmdb/Manifest
@@ -1,3 +1,7 @@
DIST lmdb-1.1.1.tar.gz 880359 BLAKE2B b202154eae151d3748e9e90fcb71a3c8a722923c2583e469ef1a0017a4c3dfdfd62d99db24fb79e7da1fc7c6a4fb695d9db5ed6a67750967788a12fe0ba24761 SHA512 4621c87dd646f8ca37f4cdc40ffa2fe809ca4da21b335856e50e6d0ae07f3828d424cde9cc383e4cdc761cd9311eb504d67678a33de51c1931a006ec86a2fcd0
+DIST lmdb-1.2.0.tar.gz 881437 BLAKE2B bcb045868c100bcb82daed99bdbd73699dcb5a0e982679f1d9f49747f468e2ab2cbc412ba020b9deca7263fece501c25d984397ee2969187c8118da920c691aa SHA512 75c7aeb3e98ffddb9e40b4eb7404afd3c6ade93753488eac2cb5facfab3ec9b660d925b8bd1c40ca5f8180cb6ca33483020bb4c5ddc074b841693ba278883529
+DIST lmdb-1.2.1.tar.gz 881515 BLAKE2B 76d56e046b5a481411c9a180989da0d1c4b7371058e38abe6d8a6b76f7e2bc62678459241d319850cf739b7b067f3e89d309e5f9a538a187c52c1044fe8b768d SHA512 fa763e24c8f278e0b9c379f39329b7b80051e10d5d8edfdd631486490cfbe5c7bc641d885ffb9f298c0c07f7e6901cc826023c472f98b430a4ec9c0bc71139d5
EBUILD lmdb-1.1.1-r1.ebuild 811 BLAKE2B f0e38c082186bfd8a0178e4d7cfadba41373a5d38a5bfffc25db1efd8c0389ca63f95197344c45c92c3144e85cd78a1614eb662b5cb62bb4080bd514fa681ad7 SHA512 bfd35e5e39ce4021687aabd371d618b1174bdc2521ebb1069d0681e75248ead0fe167e78cc6ff194e8c91455fa1c37a222554ca536659dcc9467c8896d893e1f
+EBUILD lmdb-1.2.0-r1.ebuild 851 BLAKE2B 4d708e43c8bdc6f5bf6523445512e197fd654f9af561336bd88d5e65014c95a386b7c245899534edc869e475982f32f7e073685b6a4264f6f8e66b514f7d9562 SHA512 937bdcc4237c98009fae5fce4316f13bacc38b4ea7c2039117682e902d9f438cc376cc43791cf516d788f996eacf6a3e2f53bd01a40c530d53e1134946b5f19d
+EBUILD lmdb-1.2.1.ebuild 804 BLAKE2B 61e2883315ca10151c43169da9013b45cfe2444185b6b6d5d967ab75773918da333238f1a372a38d7e912a8d8844128d42791046cbd35ed451ec47c1b649b818 SHA512 d6f37db07a8f8f00dd17112e45574ed7f7271ae80a5e8b4adc64c8c00b32da25aedb956b89d45b820102ffe77013d2aba59738081fb27b0af6d4245d9ad3f42d
MISC metadata.xml 419 BLAKE2B 7bb3bd08439249e8bcb7f64d91a707245dd2c32eefed576a4389019217c304173754628f1fdd82f147e6f7a077e2abcb6062dcbaf76d0547c8d710c8d16d0a64 SHA512 700345b4a50d602e35c983fadf73eee5da01b7d9dc4a647966277aeb7fe1fb26f583c681acf1718060dff14b195df7fa4689bad2451c475d1883b66e223ad29d
diff --git a/dev-python/lmdb/lmdb-1.2.0-r1.ebuild b/dev-python/lmdb/lmdb-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..9c9fdaea7812
--- /dev/null
+++ b/dev-python/lmdb/lmdb-1.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Lightning Database"
+HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.28:=
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_compile() {
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
+}
+
+python_test() {
+ epytest tests
+}
+
+python_install() {
+ # This is required when the CFFI extension is used (for PyPy3)
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
+}
diff --git a/dev-python/lmdb/lmdb-1.2.1.ebuild b/dev-python/lmdb/lmdb-1.2.1.ebuild
new file mode 100644
index 000000000000..2d0edc21594f
--- /dev/null
+++ b/dev-python/lmdb/lmdb-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Lightning Database"
+HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.28:=
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_compile() {
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
+}
+
+python_test() {
+ epytest tests
+}
+
+python_install() {
+ # This is required when the CFFI extension is used (for PyPy3)
+ LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
+}