summaryrefslogtreecommitdiff
path: root/dev-python/lockfile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/lockfile
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/lockfile')
-rw-r--r--dev-python/lockfile/Manifest5
-rw-r--r--dev-python/lockfile/lockfile-0.11.0-r1.ebuild48
-rw-r--r--dev-python/lockfile/lockfile-0.12.2-r1.ebuild40
-rw-r--r--dev-python/lockfile/metadata.xml12
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/lockfile/Manifest b/dev-python/lockfile/Manifest
new file mode 100644
index 000000000000..c699581f1582
--- /dev/null
+++ b/dev-python/lockfile/Manifest
@@ -0,0 +1,5 @@
+DIST lockfile-0.11.0.tar.gz 20909 BLAKE2B 8e13508312efc7eaa463e8fb80bf0a51ae3bc0adb93dee0eb52273bac40293e729de83aca98f549d12f3e46f9654c1d0f373aaba350acf7a17421c3d1fa9ea52 SHA512 6c4c69e1434194076a99f8134a2558c791675d420a17687dfd5b38c1303564392ecc388ec285d55a20027bcbcbc1b3475a489b70390796c46346b89d4b18ad89
+DIST lockfile-0.12.2.tar.gz 20874 BLAKE2B 8a1e49e8799516b44b219fb28101f3985d75fea842456e69c4357b71eb6a7be21cc56c0f9e885df8da3fb6c584ff4a47c7daad87ba34fc47a8cd40644ece063b SHA512 67b7d651d7e963a497c2604912c61eed90181cdd09c744a0ceaa26e6bbe09d1a871ce48be3949b7da7ea6b366b15492c8c8de589edeca2641ca5e6cb3804df07
+EBUILD lockfile-0.11.0-r1.ebuild 1256 BLAKE2B 3c93152c9551a79f673a46e89df357aba312d306bc796c3c01a8caba3de608c50d108e3c9907dc9b438b8b125051ab0d3d1424514713871c98152d933c0597de SHA512 2dec277045cf38f28b175b3100047cae8e8f5d169ce6a33e14f5b10d9a249d25dc12d21bbb0530c82d5671df213a11417d359a8fc8d15f35c4729e09b3a5d788
+EBUILD lockfile-0.12.2-r1.ebuild 1081 BLAKE2B f53644932c23dfb045fb5dd72e2e45faaa5710a866905cb020ef9f25a6639e5151e4306be2cd43c5384ac056f9050dfa1ab06e5258959fc879a166b1e1a86856 SHA512 f337ffbe0d427b99ce010a94b2bb22e5d1411e90acc3038f17142ed9225c4dd149d19eee59388ecf50b8b5a570351e9591ffedcd0b58f70dafcf36d1492b239f
+MISC metadata.xml 364 BLAKE2B 504dcb4ca67f92ab6554918b7dfa48d80f31439e35d6d1b5af441dde50455d27bea1f9e0f2284676cd9190cdacc839a322ac4ae556b45a371f98d5f032c5ae5c SHA512 b736cd5f710ac2c628d8379aa69fbf3cf5015a1edd80405ee695d56d0a0f86bc40c8ecbe70083338e6b7fdd115d11318358f5fd04b2397e0ab5ab7b315bfad5b
diff --git a/dev-python/lockfile/lockfile-0.11.0-r1.ebuild b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..b26c70c9c2a5
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="https://launchpad.net/pylockfile https://pypi.org/project/lockfile/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="doc test"
+
+DEPEND="
+ >dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+
+python_prepare_all() {
+ rm requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ emake -C doc/source html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
+ nosetests || die "test_lockfile failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/.build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/lockfile/lockfile-0.12.2-r1.ebuild b/dev-python/lockfile/lockfile-0.12.2-r1.ebuild
new file mode 100644
index 000000000000..50b7b609be19
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.12.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="https://launchpad.net/pylockfile https://pypi.org/project/lockfile/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ >dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+
+python_compile_all() {
+ use doc && emake -C doc/source html
+}
+
+python_test() {
+ # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
+ nosetests --verbose || die "test_lockfile failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dodoc -r doc/source/.build/html
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/lockfile/metadata.xml b/dev-python/lockfile/metadata.xml
new file mode 100644
index 000000000000..385ef5e60b67
--- /dev/null
+++ b/dev-python/lockfile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">lockfile</remote-id>
+ <remote-id type="launchpad">pylockfile</remote-id>
+ </upstream>
+</pkgmetadata>