summaryrefslogtreecommitdiff
path: root/dev-python/loguru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/loguru
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest4
-rw-r--r--dev-python/loguru/loguru-0.3.2.ebuild4
-rw-r--r--dev-python/loguru/loguru-0.4.0.ebuild24
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index 7fc340597832..b3a4aa8cfe6a 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1,3 +1,5 @@
DIST loguru-0.3.2.tar.gz 378160 BLAKE2B 83301f5bb79d0edb20d211e8ee4d05b3b93a0a9f13f13b2ff103f1e9759f227b80e5571ccda48098a1e45658d99a54768fdf456ffef7a13d08375ce62ad876e1 SHA512 e78f5f43fbf4891ff9b9a21c1a29e4f02877f73a09b7b7df25076bffb25a094eef561c469b22cbb999979de4dbf81df2298681fa219dc684f15fe7c52ecb5359
-EBUILD loguru-0.3.2.ebuild 992 BLAKE2B 3b387ea2b110c3e3c6b8461bd69a3185c5ad8040047120fdb5e142f041f866718ddf1429dc6a0f43198b10aafe2465022ccfcab6d8837e871218e1b21ca697fd SHA512 750356f6f06edfbc42873ac1278854519a40f9382092fb706a1fcb64e662bccb915951102edb48a0d12cc3931d7005845805a207c690ca31adf8edf40b88ede6
+DIST loguru-0.4.0.tar.gz 401317 BLAKE2B 00418647a240875706059d9f677a8377c3d169b92add3519c68a89ad2609ff48a55d735793749ab92a706f33611ba6d1b88a0b2e067ec6e80eb7827245bcb116 SHA512 2829cb888585998de5d1cfca815dbca32baa2c4b6ec61d6f165750e6ffaf847c6317846d8626189162131b36a6f2510dcb66bc05e72be76fabda11002a89767f
+EBUILD loguru-0.3.2.ebuild 995 BLAKE2B e017a9a3db635092289274ab7b6fc8fece60dcbce1d6763dee5124d3ea19558dbb6fd885bb9437a9c9feed9dc53700b5af17db3711d8a082ada353966d4ab8fa SHA512 c8d2a10ff2777896faf53148ca00b06d3e7046050a42e59b68359eca6fc9d39e6f1c00e0f16fb65ce3766b39001646f95ea616313c6c39dc053851b324a8c9c8
+EBUILD loguru-0.4.0.ebuild 656 BLAKE2B c12daee7cc82dd3e3f2f2cbe97618f94baf12320ff29a1ba13a537c55a67f3d0a001217bb8c01353e15b3100347d30a5833bd08ded28362d8d052d51adc9ca98 SHA512 fd591aff2a4fd4c44abb4f0a54c4f67c41a838c89b1ff9820aed1f26096c8552bbbf41d590fd13fffdfd532f62b1cf941c9bdfb1dd1d2d5fa842847dc0384138
MISC metadata.xml 683 BLAKE2B bd44db6c47f17a714eb8080d63d5002bbedf247787d568735f87f8aa01a13fc32d383f4eab2b92536a2f98f5b76b0ae01c407bf3c746b08c668ef562cf488ed0 SHA512 8a671ba69aa489f384c7074623f62c03905442b14b6b12bc9f306416a66390a334dcdadf84a5485936b47ff9992ac87e35ffbc8ae17d035b381f53f721b2369b
diff --git a/dev-python/loguru/loguru-0.3.2.ebuild b/dev-python/loguru/loguru-0.3.2.ebuild
index f7db000b4db4..fe109d742627 100644
--- a/dev-python/loguru/loguru-0.3.2.ebuild
+++ b/dev-python/loguru/loguru-0.3.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
diff --git a/dev-python/loguru/loguru-0.4.0.ebuild b/dev-python/loguru/loguru-0.4.0.ebuild
new file mode 100644
index 000000000000..aed8f0048adf
--- /dev/null
+++ b/dev-python/loguru/loguru-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="https://github.com/Delgan/loguru"
+SRC_URI="https://github.com/Delgan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/aiocontextvars[${PYTHON_USEDEP}]' 'python3_6')
+ >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
+"
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest