summaryrefslogtreecommitdiff
path: root/dev-python/louie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/louie
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/louie')
-rw-r--r--dev-python/louie/Manifest3
-rw-r--r--dev-python/louie/louie-1.1-r1.ebuild32
-rw-r--r--dev-python/louie/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/louie/Manifest b/dev-python/louie/Manifest
new file mode 100644
index 000000000000..b5e4297a28a0
--- /dev/null
+++ b/dev-python/louie/Manifest
@@ -0,0 +1,3 @@
+DIST Louie-1.1.tar.gz 22306 BLAKE2B e7cd79003113f235e4058f60ec71325dd9bad6082aa66bb115e3adde3e75528fff170df5e547355871f9aaf49393bd89e1da7abc2df598132016e8f0b324d8a6 SHA512 4f5426da4bfbf7a5928007a82e155414e7db9d466397eb9cba6a5fcfddccf4bd162071e5d551fb6ffd41f0b780097a89eea6c268e2d4fb32264683f796d85ec0
+EBUILD louie-1.1-r1.ebuild 697 BLAKE2B 31c2f3b1878299c2d0ab3e66b0e39adbbf774719533e84acb09b541c153e0743e025821042e28ec9f05b160ea8de9ad81026480bbf013e820d879f273fc088aa SHA512 23e311d0c284304ef54fe143ee09919c805746be6490b432bfecd3ab81436b722552f719d822762167b0062c9f3d6b00318d4654768a694d324b48abff74d680
+MISC metadata.xml 308 BLAKE2B f3d2320a61138ae287468fddb81dca0fd3a12500c95f0148ee2c4e67437353cba3198f1560c296a0bbcf985156b183a98e5179ca7da668444911b890903a4da8 SHA512 6559bcc872bf9bfdb5fb0bb7b3f8b61dc0bbba13fe726aa00bd316dcae42c13d2eeb887cd77168810ca6333e442a9deb82cc9de3fd7f2bd66bfea662287e63ed
diff --git a/dev-python/louie/louie-1.1-r1.ebuild b/dev-python/louie/louie-1.1-r1.ebuild
new file mode 100644
index 000000000000..7ff8a31b7ae7
--- /dev/null
+++ b/dev-python/louie/louie-1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Signal dispatching mechanism for Python"
+HOMEPAGE="https://pypi.org/project/Louie/"
+SRC_URI="mirror://pypi/L/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${P^}"
+
+python_prepare_all() {
+ sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/louie/metadata.xml b/dev-python/louie/metadata.xml
new file mode 100644
index 000000000000..9ca525a62916
--- /dev/null
+++ b/dev-python/louie/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Louie</remote-id>
+ </upstream>
+</pkgmetadata>