summaryrefslogtreecommitdiff
path: root/dev-python/lunr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/lunr
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/lunr')
-rw-r--r--dev-python/lunr/Manifest4
-rw-r--r--dev-python/lunr/lunr-0.5.8.ebuild40
-rw-r--r--dev-python/lunr/metadata.xml1
3 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/lunr/Manifest b/dev-python/lunr/Manifest
index 7cad55d26c3c..8f91f7ca69f2 100644
--- a/dev-python/lunr/Manifest
+++ b/dev-python/lunr/Manifest
@@ -1,3 +1,5 @@
DIST lunr-0.5.6.tar.gz 43815 BLAKE2B 0d68dc098a71c1fdaaddee80605fc63a0d30492b6e329cd8f963dc740bc40fc79959bf20b159af6b88c4eb2736db6793c6fea5b74968f74923741f220a372a89 SHA512 48167c90ac1351fd3aeaefbead752d8b96b941e79edb33a4232ac588a2fa54775972c883564ea23e3d58f3f5a94ee448c27049f4410016032f5a8f36aa4c6709
+DIST lunr-0.5.8.tar.gz 834919 BLAKE2B 970cc12fb30bc849d4ef846818f93fa7b7701b1155c9b7880f3a63384a8f353c760be5dc6c37188db656e7424715aa854f20615ae652b0a5c9e656871be490af SHA512 90c279b9e91744f19c4a155947526bff749aee5d727bc38cc36ee05228a6624419a54bef4214e8195a69abcf1a5b40b29c4fa8b14bece0befbde02d13af969ac
EBUILD lunr-0.5.6.ebuild 875 BLAKE2B a551c6710b019444bc2c09e6afd5fd32a787b4d1f39e33ca59b63790f1bfd6db465073efe26b59653ee6bdd16ad3688d5f609df881dde1f5f85f80c9da234d8d SHA512 60e37e211f31fc8009d2539bb49e4236797fa2170386eaa9806306baa2b516db9e9eb2e2392beb55d8104fce3e126e2b49d074bff001bc43f8eff6ce9ce4309b
-MISC metadata.xml 465 BLAKE2B c5c9dce51449ae6c628969c4536a7ea37677438224c4812dc4162d7f8ee59d7505e0d8bcea05db1c4dddf0b5bc675246d500ba5f06bbecb779294cb1b8b83dd7 SHA512 4daacb3b576db362b14af380cb1b4616ef8a6aa206a539533d8119431c66e7f566a8f1678d3744d8644a0db8c2b047bfbf68729c1520683d167224725e0f5d52
+EBUILD lunr-0.5.8.ebuild 1063 BLAKE2B 00306b0652d883befd55bf11ba4336a6dcb5577639a1d3c50739728930b7c1603fc9fe3fb170ec7c91ed684556b67bcebc9ad3eac8a9b1e54739cbf46f0b9c07 SHA512 7de1832c9280a3420e9802f112894cb5bef765199b1cf053e54559d5cd65ac6be8baaa2ce6449135a7c369773786858fda92b6d970ce75b27684896c7fcbf079
+MISC metadata.xml 507 BLAKE2B f5dde74aaee3f47e370ee15e48d9f81ff209cb4639ea7805bda73176c649f70f6f468018765eb561a19c9b9d5e67f802196df3361d96a380dea4e30652b4d47e SHA512 bbfb375a50de20a953e4792d440a5fd6e5b972f1feb1522d993a3eed74a16c06758420ba90a274dcce74fa4b31be04aa07aa931f8d6654d97ad8060114d21bdb
diff --git a/dev-python/lunr/lunr-0.5.8.ebuild b/dev-python/lunr/lunr-0.5.8.ebuild
new file mode 100644
index 000000000000..36c77dcb3bf7
--- /dev/null
+++ b/dev-python/lunr/lunr-0.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DOCS_BUILDER="mkdocs"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="A Python implementation of Lunr.js"
+HOMEPAGE="https://github.com/yeraydiazdiaz/lunr.py"
+SRC_URI="https://github.com/yeraydiazdiaz/lunr.py/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/nltk[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/${PN}.py-${PV}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Tests in this subdir all fail
+ # Command '['node', '/var/tmp/portage/dev-python/lunr-0.5.8/work/lunr.py-0.5.8/tests/acceptance_tests/javascript/mkdocs_load_serialized_index_and_search.js', '/var/tmp/portage/dev-python/lunr-0.5.8/temp/tmpldbff36d', 'plugins']' returned non-zero exit status 1.
+ rm -r tests/acceptance_tests || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/lunr/metadata.xml b/dev-python/lunr/metadata.xml
index 5a0914daffe9..749310d9a909 100644
--- a/dev-python/lunr/metadata.xml
+++ b/dev-python/lunr/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<upstream>
<remote-id type="github">lepture/python-livereload</remote-id>
+ <remote-id type="pypi">lunr</remote-id>
</upstream>
</pkgmetadata>