summaryrefslogtreecommitdiff
path: root/dev-python/lupy/lupy-0.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/lupy/lupy-0.2.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/lupy/lupy-0.2.1-r2.ebuild')
-rw-r--r--dev-python/lupy/lupy-0.2.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/lupy/lupy-0.2.1-r2.ebuild b/dev-python/lupy/lupy-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..6385bf816a0d
--- /dev/null
+++ b/dev-python/lupy/lupy-0.2.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Lupy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lupy is a is a full-text indexer and search engine written in Python"
+HOMEPAGE="https://pypi.python.org/pypi/Lupy"
+SRC_URI="mirror://sourceforge/lupy/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ~s390 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="changelog.txt releasenotes.txt"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}