summaryrefslogtreecommitdiff
path: root/dev-python/lz4/lz4-4.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 08:19:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 08:19:20 +0000
commit6989a301768c924a6014fdce19b28de541ad557a (patch)
tree48fc14349566cfd64cf81015dcbfbfe5c4360186 /dev-python/lz4/lz4-4.3.2.ebuild
parentd897af505afa85942967dd218e3005a4ad906e5a (diff)
gentoo auto-resync : 31:12:2022 - 08:19:20
Diffstat (limited to 'dev-python/lz4/lz4-4.3.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-4.3.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-4.3.2.ebuild b/dev-python/lz4/lz4-4.3.2.ebuild
new file mode 100644
index 000000000000..358b79f49818
--- /dev/null
+++ b/dev-python/lz4/lz4-4.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="
+ https://github.com/python-lz4/python-lz4/
+ https://pypi.org/project/lz4/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+)