summaryrefslogtreecommitdiff
path: root/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03
Diffstat (limited to 'dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild')
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
deleted file mode 100644
index 9e4d45513c48..000000000000
--- a/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Get Things From One Computer To Another, Safely"
-HOMEPAGE="
- https://magic-wormhole.readthedocs.io/en/latest/
- https://github.com/magic-wormhole/magic-wormhole/
- https://pypi.org/project/magic-wormhole/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/autobahn[${PYTHON_USEDEP}]
- dev-python/automat[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
- dev-python/noiseprotocol[${PYTHON_USEDEP}]
- dev-python/pynacl[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/spake2[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-python/twisted[ssl,${PYTHON_USEDEP}]
- dev-python/txtorcon[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
- ~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}