summaryrefslogtreecommitdiff
path: root/dev-python/magic-wormhole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 09:48:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 09:48:32 +0100
commit7795d9198ccb546ad792af2694399b516fc244ac (patch)
tree0f80cd898370b3bbd31dad1b53588d38064793c6 /dev-python/magic-wormhole
parent76639e956cb332de1bfbf50143f11084d2686c65 (diff)
gentoo auto-resync : 23:08:2023 - 09:48:32
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest2
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
index ef266e080f5a..b30595913a20 100644
--- a/dev-python/magic-wormhole/Manifest
+++ b/dev-python/magic-wormhole/Manifest
@@ -1,3 +1,5 @@
DIST magic-wormhole-0.12.0_p20230525.gh.tar.gz 281332 BLAKE2B daf9e39c89d8591584b25f142de2e66757a31970179f38e2fb74e112295e637f94930127bd3c0c1cc1243ac559dc4885bab3e7892b112dbf174b0514b49051c0 SHA512 ef5be6396fb9d6e35c64baeeaaea269526f9f8127eaf1bdd7b7b693a0272885388c4d6dc9fac87f6355eff5e9fe94450aebeafd2009b7d74f6772922a2796cbd
+DIST magic-wormhole-0.13.0.tar.gz 274564 BLAKE2B 51752204231be0f3eac8765387386435830e91f541aaada7ca6ee52c8334879cdce68c31d40c3207a7bdb5657a5240930aedc36bab8e765f1081b20624ebdf3f SHA512 5c26da12ae94202684da14d7e3fa84ef173a31a3e5e42a40dcc2b8d3a6475943c813bcef9fbf904e419152a16e2cb4a85c2a69bbf0528f5fa63d056bf5f348e2
EBUILD magic-wormhole-0.12.0_p20230525.ebuild 1646 BLAKE2B def94939c61a465aa74fedda2202c369c3230eccce8dea06d19c4ba0e66fe10f260a80c785d3b5b5ab0e90f714f6b9a64a58230ae6e5b7b30bb55bab2125827f SHA512 919b1443d6e2d5b6be996c8e9a30d8c9ae0d686113c5eb8d69b01359dcbb596170805de5de80f585db5c2b10de56e49d03f25780a7473c1aba21b2f60cc32198
+EBUILD magic-wormhole-0.13.0.ebuild 1260 BLAKE2B 9831e9fbe5d07e1f5975d6a9bac42f13ad1e4220bcc6a477bef9303d56c9aaf4ef2154ea43580c9572f6abde4ea3cc4e601c5bbf6d7f11f3483a1b4c32a173f4 SHA512 393a4f7db3103d1c89b7b1327136917476fbca2384c7eddfe6c4be466397ec83a3961d78c78d65e465bfc7d8e5d1d76ee035a411ac7f48f8c5a23dc6e1a34f57
MISC metadata.xml 418 BLAKE2B 9f9b20483a6ce46113cc6307621122f2a5d36355ca9c8290af95b88c6ed6bb9320810da1eccf9c53d310fd8faea3796094b1c1260032406aa9adff37dc95ce51 SHA512 ef39741b0b041bf889d138efea1f784453dce8cf982d170dbfe26ace415bb186672a7bf56b1c4a586c0820997522a45f92fa40b37936f4c90ec731498c3c7b69
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
new file mode 100644
index 000000000000..43b48954d293
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="
+ https://magic-wormhole.readthedocs.io/en/latest/
+ https://github.com/magic-wormhole/magic-wormhole/
+ https://pypi.org/project/magic-wormhole/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/noiseprotocol[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
+ ~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}