summaryrefslogtreecommitdiff
path: root/dev-python/mando
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
commita15e8dc7444560123d7d4be1bccb19afd5b611d0 (patch)
tree6e26ee0323c09494a66d0f78c4b81e305bb0d096 /dev-python/mando
parent3dc4de6331223493015f198dc61854af604da86c (diff)
gentoo auto-resync : 22:10:2024 - 04:04:46
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/Manifest2
-rw-r--r--dev-python/mando/mando-0.8.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index 05851f38af8e..1433385dc30f 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1,3 +1,5 @@
DIST mando-0.7.1.gh.tar.gz 37802 BLAKE2B 1caf437248f1b1397888674fff0171680fd1d2cffd1d3394869edce4fef0d214fb52fc0eb7435ef162722f128f129f8d19385e65661914c51f78108b64f8db38 SHA512 a25dfd57e833416cbd64933ca3970712d28c2e2ed172091a0d0c082f486c707d0061afb071e3973e7e42b654d1a6e70f4909b1254fdef493471dc0ae9d3eb62b
+DIST mando-0.8.2.gh.tar.gz 37606 BLAKE2B 0f9ac55167a94df20f562ede072cebfd8db1a105409cf8aeb7b882e2239c47f50119dc3b3fd3fffeca48bc1e56377b91f7fbd52fe18b6ba2e5bc9da1bee8eebd SHA512 e389fe1935c7e7e6812e98b874c5760a5fb1178fcacefdbecd47b3a2fd41457647da424baaf0065367e3c63903116ac7ad2e6dd20fc428d2831290eafe3486d4
EBUILD mando-0.7.1.ebuild 848 BLAKE2B 41c5ca9bb6eecf111db94ddf974d4005fdd316b34b05601d8fd9dc203c7338076201e94381e932161afd574345603b6788079113f45187aa12e6c70a2e0a159d SHA512 3a6d2c1c014df79488970c519be80bca2d7802ffa48ea7353b5e3d0d18f5c12b57e76d9d61aa4c15a18a4629169eb01cd0c075935dd262d06eb028d7a5233b6a
+EBUILD mando-0.8.2.ebuild 809 BLAKE2B e8b796e1455ca3e90ab5489a0e75cc7801b2cc91b69de78c722a2bc6059ca801e95403ddae14686c997c08c244a5d0c02be0df0375c186c3fd0ef6ae7fe06589 SHA512 3c53bd1b7104b40eca03709fd052c96deb2bf535ca40a23475524441d20109240aa8b5e7e819f66a5a6dfff22efea32b9788db0fd830fc87a9b4780ff2ac4c64
MISC metadata.xml 384 BLAKE2B 39f50a83044f29ba462a2760e5c8662776128696c4311f7a0496cd919ea91bf45e041a08aa7aeb4f5ac9460b3b2dbe22a6d313b848394d2689775b840756951a SHA512 2cfbaf01b8009454663391240647316bf8258cc513bc544a80b3b8cd263baa9f03fc2e66d1b7952b129d69e911f2216f6e10487840e32c31592583bfc6ea760b
diff --git a/dev-python/mando/mando-0.8.2.ebuild b/dev-python/mando/mando-0.8.2.ebuild
new file mode 100644
index 000000000000..17b6b28f6ba4
--- /dev/null
+++ b/dev-python/mando/mando-0.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create Python CLI apps with little to no effort at all!"
+HOMEPAGE="
+ https://mando.readthedocs.io/
+ https://github.com/rubik/mando/
+ https://pypi.org/project/mando/
+"
+SRC_URI="
+ https://github.com/rubik/mando/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}