summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib-venn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-28 22:42:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-28 22:42:59 +0000
commitfc4ad6e568738af8995c2e87896c671c39eb8c72 (patch)
treeb56fb204081c089b8a979d01e8badc2c819f8cf0 /dev-python/matplotlib-venn
parent417348c68a53a9317b6afbf343381518a405f682 (diff)
gentoo auto-resync : 28:01:2025 - 22:42:58
Diffstat (limited to 'dev-python/matplotlib-venn')
-rw-r--r--dev-python/matplotlib-venn/Manifest3
-rw-r--r--dev-python/matplotlib-venn/matplotlib-venn-1.1.1.ebuild47
-rw-r--r--dev-python/matplotlib-venn/metadata.xml12
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/matplotlib-venn/Manifest b/dev-python/matplotlib-venn/Manifest
new file mode 100644
index 000000000000..2624e80ced93
--- /dev/null
+++ b/dev-python/matplotlib-venn/Manifest
@@ -0,0 +1,3 @@
+DIST matplotlib-venn-1.1.1.gh.tar.gz 978290 BLAKE2B 21f0541df95428557e60eaca95e7e2749825bb36c69855b7adca54141af7c343073d62f99fe3b45ae17dcd514cd91813b188e426f61e415f9a353ce214588b71 SHA512 b01fe31122d8a4f6914aaa24ad09cc571536952f1d22231c7c59a760c2baafce7d6e7bc91de8bfc1efd5d2aca18371f6b834908382407fdb5add806a137d8e16
+EBUILD matplotlib-venn-1.1.1.ebuild 1010 BLAKE2B b1265de8991ffab83df967cb80533fa07a72fe0a0e9eb90127be36375ca74fec92867b1e3eab24963f664179c1d61561580d76a21805007ff13168dae404dd75 SHA512 225990156b14063d70118143182395bb0c0301ba63a4576bfe7ea080af229278f1f52ae43521aafb2f101f4f5fd021c4e4e616fef4b56ff654edbc874f5558a5
+MISC metadata.xml 388 BLAKE2B 3a38b2b64e30b3aa0e854b1cec424b622095fde81af938c5432c0b078fd92af92824562dbbc02a4be130af7b8ba41e1de2aebcdd059140edf07b41d7fe906bed SHA512 503c292b6c4c8e1d5fcca62e7ab653eb5300ec5cb15211136c37d6c51e268135ad825facce2a311ea737492b572cfe350d3efa6bb3a8258ab0dcf5550c5829ff
diff --git a/dev-python/matplotlib-venn/matplotlib-venn-1.1.1.ebuild b/dev-python/matplotlib-venn/matplotlib-venn-1.1.1.ebuild
new file mode 100644
index 000000000000..8522cd6a04ec
--- /dev/null
+++ b/dev-python/matplotlib-venn/matplotlib-venn-1.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plot area-proportional two- and three-way Venn diagrams in matplotlib"
+HOMEPAGE="
+ https://github.com/konstantint/matplotlib-venn/
+ https://pypi.org/project/matplotlib-venn/
+"
+SRC_URI="
+ https://github.com/konstantint/matplotlib-venn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/shapely[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: some minor number mismatch
+ matplotlib_venn/layout/venn3/cost_based.py::matplotlib_venn.layout.venn3.cost_based.LayoutAlgorithm
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/matplotlib-venn/metadata.xml b/dev-python/matplotlib-venn/metadata.xml
new file mode 100644
index 000000000000..96c87c18e907
--- /dev/null
+++ b/dev-python/matplotlib-venn/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">konstantint/matplotlib-venn</remote-id>
+ <remote-id type="pypi">matplotlib-venn</remote-id>
+ </upstream>
+</pkgmetadata>