summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib2tikz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/matplotlib2tikz
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest4
-rw-r--r--dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch24
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild39
-rw-r--r--dev-python/matplotlib2tikz/metadata.xml17
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
new file mode 100644
index 000000000000..82cf3bb09171
--- /dev/null
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -0,0 +1,4 @@
+AUX matplotlib2tikz-0.6.11-pipdated.patch 639 SHA256 f98244a71104b31d2b03b960f616e4c8079530d526d8fab55faaeb90137ed646 SHA512 f2c8f4e8af2a5deedb1cb1f38f51c7b5cc70aea54a76647664c68531b98b80058622fd948adf56eaf3815df9c27075694ff96d8ddbb60edb4bf67d62f579500e WHIRLPOOL 8e5fa04554671b96f61e6c5670436a00ba9e206103380d585ff97babe5d917e9e080eea89404ff3de2f24823b905087a2f2a6d23c59a01892b283eb04986278b
+DIST matplotlib2tikz-0.6.11.tar.gz 524298 SHA256 79c9f141fd802fe5863d2eaff6c67476d02ca474433e65990c935241a2591994 SHA512 eda5042f1db35436ca56256cb858fa11b48d497f621183475d69381b0b10ac67f9447522e1b78c1a331337e34eb159b5ffeef9655a8c0dc4ccab22b7afcb5e96 WHIRLPOOL b09025b9444e0a0ec122fbb7d6d90e32e043c3a86e8b7454ac3fdc0ba03374f5648491a4564bae7ef622a536f4ec92e762a68816d64621da6df44fea2c404c8c
+EBUILD matplotlib2tikz-0.6.11.ebuild 966 SHA256 0a45b2fb418fb8bd5df6bb5a6177fd1b4edfa487cf89182e9993bee6773bd91b SHA512 a614afe5abf1e043d6f61c033a77b03a0cf4108c0499903fd1aad99e5fef518c7025402822a2c7c412db02ad84e7c5922a3e16a35fed542747b3558fcbea28ab WHIRLPOOL 90158cc980e2e597af7d5566d5dd898a40021dfde385a01f8f1de9d2d238c09b0c067b96a181bde6dc833515d37315c428cd6c074b899a41c12f0c6e26eaab1c
+MISC metadata.xml 976 SHA256 bbd0ee639b2f20cf03f6f450fa9e7486cb1bf286b4b58e2f555a489345de6872 SHA512 5ce41d4236c17a50a9a9949974c8c9fbaa5ca0c46cd628b34a8266227982b780c5fa5f2fe5667d51961f64c19c73d377363558f28756d2bbb8a88f1c4ced19b1 WHIRLPOOL 3e3e5a5edb35e07284a4d9447829e66e54b98bf612af5ebd1164044583ef52a5cb08653772e3122825fc73bff166b5103c2345fb664a6da9bfc86d32c38718df
diff --git a/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch
new file mode 100644
index 000000000000..3b7cf2ffbe51
--- /dev/null
+++ b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6.11-pipdated.patch
@@ -0,0 +1,24 @@
+Remove version checks using pipdated.
+
+Patch by Marius Brehler <marbre@linux.sungazer.de>
+--- a/matplotlib2tikz/__init__.py
++++ b/matplotlib2tikz/__init__.py
+@@ -16,7 +16,3 @@ from matplotlib2tikz.__about__ import (
+ )
+
+ from matplotlib2tikz.save import get_tikz_code, save
+-
+-import pipdated
+-if pipdated.needs_checking(__name__):
+- print(pipdated.check(__name__, __version__))
+
+--- a/setup.py
++++ b/setup.py
+@@ -34,7 +34,6 @@ setup(
+ 'matplotlib >=1.4.0',
+ 'numpy',
+ 'Pillow >= 3.0.0',
+- 'pipdated',
+ 'six',
+ ],
+ description='convert matplotlib figures into TikZ/PGFPlots',
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild
new file mode 100644
index 000000000000..437c6ed6f555
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/${P}-pipdated.patch" )
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/matplotlib2tikz/metadata.xml b/dev-python/matplotlib2tikz/metadata.xml
new file mode 100644
index 000000000000..9c08eac0171c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>matplotlib2tikz is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of matplotlib2tikz is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of matplotlib2tikz retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
+ <upstream>
+ <remote-id type="github">nschloe/matplotlib2tikz</remote-id>
+ <remote-id type="pypi">matplotlib2tikz</remote-id>
+ </upstream>
+</pkgmetadata>