summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-python/matplotlib
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest2
-rw-r--r--dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild9
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index a6f2b11c47b4..97f858cd0558 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -5,6 +5,6 @@ AUX matplotlib-1.4.3-cross-compile-3.patch 2202 BLAKE2B cac5953ba4d075d232f9e451
DIST matplotlib-1.4.3.tar.gz 49933525 BLAKE2B 40ea29ef7197d364f9caea63904b11231a4f74ca93184de8b1f8c7f78713cf887ea8a6fbee1b3f545c895eb353e0eeb5d65308657a3138986fb080ac44164427 SHA512 51b0f58b2618b47b653e17e4f6b6a1215d3a3b0f1331ce3555cc7435e365d9c75693f289ce12fe3bf8f69fd57b663e545f0f1c2c94e81eaa661cac0689e125f5
DIST matplotlib-2.1.0.tar.bz2 33051088 BLAKE2B 6a97909a44ca37c3ec09a9e723909bb0169828e56daeec5711220a6caac632d19e77ef2fc042a61cb82760c9750d04753654761a707b6265a038af9c55b91bd7 SHA512 872ff86e989b4e9352663f4abde1768aa05b1adea3e1b234efdb301429d421718314b27950e508d92df8fc9136764b07e8a6861b66512e9695a496993076bb5f
EBUILD matplotlib-1.4.3.ebuild 6150 BLAKE2B ab34b10ad72a013c9ccae7c6b34b2f624169c44df8a149dde10a6fb5448f928bdfb107e39cc220b54c5460be1645d3bcbf8278a37b20f3906776aa0f2094b715 SHA512 9e6e415962ad4e3699bde4b2e9701ca9141a72bb7d1c9097e3bda541c2d618524eee7a64ddc22a13f2d228c2e32296a4d88592ffb6ecdb366c590f70e01a2b46
-EBUILD matplotlib-2.1.0-r1.ebuild 6045 BLAKE2B 457da44552492b01672102e36370547396b930fa2e5a1b6ec256b732f88aad72a38bd5c5ab42e5e65f103d9e7041f73eeca431789d687adb436ce7e086ce67ae SHA512 65f24a8a7add5579efece30ae04590e57d34a4fb1409621699e991bd3e409f1eee47dee0e30d3cade94755f5dc28a5535404b9f7019a19b3db48011fbee5eca2
+EBUILD matplotlib-2.1.0-r1.ebuild 6173 BLAKE2B 45bda87d10e48cb942e015b518deb5476f40c64ec79a7acca3366f49d70da8036068353a3766d094e00b8108718a8aa67c34cfaa4ab37f2151322c73d8520896 SHA512 e40659b624f307e591c32f9b9f2e9aa181e8a3bdeff45535be07141b4f2657b066ded21de0adea3cdf18903cdb86882aa425a79432a4d906982de776171561c1
EBUILD matplotlib-9999.ebuild 6396 BLAKE2B e1e7d6415cadc503db5796a8aba507aa6a94f8acb7e529caeac9d71537570293d75293b607d20a33b94a7352fdcec0e2c1de8d6302f981a1cb15d15585991951 SHA512 1a6406602fabea4b12911a89d34e69fed7b418c3127dac5679ebfe706e144aa62c93f3aa19ca832d75fdff0b4f2c5e5029a92ed3e1a8fa6bd61973cedf5504cc
MISC metadata.xml 1063 BLAKE2B 396b976a60c89ae2b6bb9d365a8234663994f561a99ac0d59385a15245ae245fc09cdb6626b79a63cae53651c39d2df97ea8825016be0ec3bce7d6ad60cd15d5 SHA512 25344a9f8d7ae73f1ec9f493cef17925c94fc4cd44486a9928debbd18ba53010455393e3e97fc70e67a9afae9d6c15b12688af16e5e9f7e090748481969eac4d
diff --git a/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild b/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
index 37e6b936a7e4..f50fb4db1178 100644
--- a/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
@@ -34,18 +34,19 @@ REQUIRED_USE="
# #456704 -- a lot of py2-only deps
PY2_USEDEP=$(python_gen_usedep python2_7)
+PY2_DEPEND="
+ $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)"
COMMON_DEPEND="
dev-python/cycler[${PYTHON_USEDEP}]
- dev-python/functools32[${PY2_USEDEP}]
>=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
- dev-python/subprocess32[${PY2_USEDEP}]
media-fonts/stix-fonts
media-libs/freetype:2
media-libs/libpng:0
- python_targets_python2_7? ( dev-python/backports-functools-lru-cache[${PY2_USEDEP}] )
>=media-libs/qhull-2013
cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
gtk2? (
@@ -59,6 +60,7 @@ COMMON_DEPEND="
# dev-python/pycxx
DEPEND="${COMMON_DEPEND}
+ ${PY2_DEPEND}
dev-python/versioneer[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
@@ -82,6 +84,7 @@ DEPEND="${COMMON_DEPEND}
)"
RDEPEND="${COMMON_DEPEND}
+ ${PY2_DEPEND}
>=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
gtk3? (