summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/matplotlib
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest2
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild13
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index a1028a1d338e..da9a4fb8f9ba 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -5,5 +5,5 @@ DIST freetype-2.6.1.tar.gz 2302080 BLAKE2B 6a5fb98e5fa6cf4b7d7533ad44e364227d8c2
DIST matplotlib-3.5.1.tar.gz 35320470 BLAKE2B ebf69b62ac587c61ecf8442abaab302019f63a3c9d8db6f7f7fb32f4d14da554fd8305ea6dfed2ff86a5af4e7e4d2b81f14802692fe50c986f7da8545bd26c00 SHA512 a317dbd748e5fc1fafcf80020cb6d38a8888431487beded97acd59d759e67e54f59506b642e4a03d4351c1ac050d15e3f2e2b5443433debc78ddad52881c8d82
DIST matplotlib-3.5.2.tar.gz 35210006 BLAKE2B e3f90a0cf1d28f041a8cdd6920a8a4efe16169bb4acf85f7b2562196db306eeb692218728ea33c7b62214e7894e83a104954cbef38c45ccbb4f630bd35c0c36b SHA512 32844dfa85dbc43360c1773d748a58d2ab089111c51c825da62956c778a0eeaf10ca33a5c6c094295388a80d5873a2e1b17484e02b653e9e8e5ba98659329974
EBUILD matplotlib-3.5.1-r2.ebuild 7232 BLAKE2B 38969ec1fd4c035afe1be859825105203abe9ecc0c9ef409a64fe4e041d87324205e58c8085c628bf80a11550f453351ef518807c4f5365092bfc6f9498b213a SHA512 8c7424c236d0348d23c117d0433316c92d85fcd1902d436b418bc2c0602d648cfa8d24f8ddfb3ada0b8d9e68feda3e9526c93cf9dcf6569db516e2596581a886
-EBUILD matplotlib-3.5.2-r3.ebuild 6997 BLAKE2B e8a4d3335cc9eee119a79619f02e17974fe68590ba942aec57da41bcb40ac775d4745947885d231ca614598bd5043c8127716872e98e27756856b161c24357a1 SHA512 ccc6d038bc5da66389018b8da7c0ce74a9905aab15918f2186b4ee3d577d59c6aa703d8089ef64f2192f9a6a3c0b7b171235c3bff045528a28b3012e3c17ef48
+EBUILD matplotlib-3.5.2-r3.ebuild 7395 BLAKE2B 02444837a329cefef7a1580d54a681fd67183991d49a976c3d77a2919600539553e4cf4885ab47e03b63f7860bcfb3ebf27007ccfed543eecfb5004b9cc03846 SHA512 c7c3308412eca5d9d2cb76c137dd48a459cae6297866e97e6d485954c52c353be4d583bb77ba44f9d4bd69e92edeec49762e1deb258b4a2d6cc2810ad10fe74e
MISC metadata.xml 1075 BLAKE2B 6e2f62f6788e5a673bd54e375e6c7e8fb32d4dd181a48cf62582b93f78ef7a0e513417d24e940844188d5ab38bb2946c09e80d40706c207648c95eeac672a796 SHA512 38d935eed141df3a8d675b51a547135c9a357ab2058292640a9e98a07e3e3cc70348011d8c4f7f9f0ddece9531b56a1b2dfb2245cf1dfe065d43dc834ca78748
diff --git a/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
index eb371d6af08c..21416002903f 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 flag-o-matic multiprocessing prefix toolchain-funcs \
@@ -30,7 +30,7 @@ SRC_URI="
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="amd64 ~arm ~arm64 hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 sparc x86"
IUSE="cairo doc excel examples gtk3 latex qt5 tk webagg wxwidgets"
# internal copy of pycxx highly patched
@@ -80,7 +80,9 @@ RDEPEND="
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
)
wxwidgets? (
- dev-python/wxpython:*[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ ' python3_{8..10})
)
"
@@ -247,6 +249,11 @@ python_test() {
"tests/test_rcparams.py::test_validator_invalid[validate_strlist-arg7-MatplotlibDeprecationWarning]"
tests/test_testing.py::test_warn_to_fail
)
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # https://github.com/matplotlib/matplotlib/issues/23384
+ "tests/test_backends_interactive.py::test_figure_leak_20490[time_mem1-{'MPLBACKEND': 'qtagg', 'QT_API': 'PyQt5'}]"
+ "tests/test_backends_interactive.py::test_figure_leak_20490[time_mem1-{'MPLBACKEND': 'qtcairo', 'QT_API': 'PyQt5'}]"
+ )
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering