summaryrefslogtreecommitdiff
path: root/dev-python/matrix-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/matrix-common
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/matrix-common')
-rw-r--r--dev-python/matrix-common/Manifest3
-rw-r--r--dev-python/matrix-common/matrix-common-1.2.1.ebuild29
-rw-r--r--dev-python/matrix-common/metadata.xml16
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/matrix-common/Manifest b/dev-python/matrix-common/Manifest
new file mode 100644
index 000000000000..f6fa52d4020f
--- /dev/null
+++ b/dev-python/matrix-common/Manifest
@@ -0,0 +1,3 @@
+DIST matrix-common-1.2.1.gh.tar.gz 12598 BLAKE2B 94f25d90c9df948054739cee39033c1f261e61300aa74b7ce606cf8a3c82e716687aa57ddb0f72b8617ae56c21486b50a68f9e6c8611e2f8b19c33b0d2a557e7 SHA512 9ab05d6aeddf4915970916d34e625b7a059823e56ba8868f955cf8971a51ac31891304a7fb00170c60c6b107f7526565f67bd78416a466c50092954c5b422114
+EBUILD matrix-common-1.2.1.ebuild 684 BLAKE2B 5a032ee9d28dbb9eb56754966fb4d6381a777bebc9a88efdf5a08da9b83c731fe2e7e108653e17a8563f47f5347b552ebcace2ac152fa5a4c5ca67546bd0a498 SHA512 7ec15173120d7c18e900d6628d0997aeb9db9762c93878f3f851b2cbcb1945de0c868e0b92ba2902d6aff9910ae60270d2e1886df809fb308d26cc96f128efb5
+MISC metadata.xml 538 BLAKE2B 3f2762e9f75ccd4f288edf89417b6a3556628e4b8525e33346148ccffbf772024556069b6b3f59ac71c2a262ec4644e83fabc1ed872741a6b999992cbba454d8 SHA512 ba1bdbf10e9ecdd0e83c483f625366a0467e4be65576450fb5721b2bb1e1b06785ca8a71b67f5b3e1858f756d2463f8623a758c64e27a6aa8ab1e780ddbaf704
diff --git a/dev-python/matrix-common/matrix-common-1.2.1.ebuild b/dev-python/matrix-common/matrix-common-1.2.1.ebuild
new file mode 100644
index 000000000000..fbbe4a43703d
--- /dev/null
+++ b/dev-python/matrix-common/matrix-common-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common code for Synapse, Sydent and Sygnal"
+HOMEPAGE="
+ https://github.com/matrix-org/matrix-python-common
+ https://pypi.org/project/matrix-common/
+"
+SRC_URI="https://github.com/matrix-org/matrix-python-common/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/matrix-python-common-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/matrix-common/metadata.xml b/dev-python/matrix-common/metadata.xml
new file mode 100644
index 000000000000..88ed39af8ea2
--- /dev/null
+++ b/dev-python/matrix-common/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">matrix-common</remote-id>
+ <remote-id type="github">matrix-org/matrix-python-common</remote-id>
+ </upstream>
+</pkgmetadata>