summaryrefslogtreecommitdiff
path: root/dev-python/maybe/maybe-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/maybe/maybe-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/maybe/maybe-0.4.0.ebuild')
-rw-r--r--dev-python/maybe/maybe-0.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/maybe/maybe-0.4.0.ebuild b/dev-python/maybe/maybe-0.4.0.ebuild
new file mode 100644
index 000000000000..bdc5651f4a04
--- /dev/null
+++ b/dev-python/maybe/maybe-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="See what a program does before deciding whether you really want it to happen"
+HOMEPAGE="https://github.com/p-e-w/maybe http://pypi.python.org/pypi/maybe"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/blessings[${PYTHON_USEDEP}]
+ dev-python/python-ptrace[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/pytest-runner-2.7[${PYTHON_USEDEP}]
+"