summaryrefslogtreecommitdiff
path: root/dev-python/memory-allocator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-python/memory-allocator
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-python/memory-allocator')
-rw-r--r--dev-python/memory-allocator/Manifest3
-rw-r--r--dev-python/memory-allocator/memory-allocator-0.1.3.ebuild31
-rw-r--r--dev-python/memory-allocator/metadata.xml34
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/memory-allocator/Manifest b/dev-python/memory-allocator/Manifest
new file mode 100644
index 000000000000..037b7db86c43
--- /dev/null
+++ b/dev-python/memory-allocator/Manifest
@@ -0,0 +1,3 @@
+DIST memory_allocator-0.1.3.tar.gz 19692 BLAKE2B e3e33b4d35455c7cf38eede4f8acfb5bddada59364de53c8ac37fc18e0824a947b85b4c6e3ce9b2f817948c6e83709c17cdf68fa3ebbe6b562d315420235f0cf SHA512 41cb850346b1aead18c82b0eca48791336315b5da8c2beeccec4eae90f55425f545a7cfd42c8cb9bd9f8c25a3a31b7334e304c0d726fdd848df26ae72ec7b7a7
+EBUILD memory-allocator-0.1.3.ebuild 986 BLAKE2B a4897da65735dd9fa34a2b8d0ae21f3ef599e350274ddf4e87de51a9ae983f255f9486c25c6efdcd6a1b0c2433ff4a1a7b29aa709860236079fd620fa536816a SHA512 24b9622a0cfc7f2e6cb034fb21a6d08b6b662d6ea5a8b8ae68c13e718844736ad0577ce6a775026b7fba7ba9292f351f4c872aeea9d0ed0a4e01d5207c52ed6b
+MISC metadata.xml 1092 BLAKE2B 495f160cb60544af5d379c32016e61ecd451b174223c0c919c782180aa6474e9e2dce8150f43be5174e3d8a55cab492469f7aafb5d5cb19e469435d672fcb143 SHA512 7118041702e4cd3226632896df70032054dbbbc9aa985a51b83d513ff451b5123d8adb58c80f353dbdd0ee5d783dc378bb417bfc75b2dce935e2d15edc2e4c4e
diff --git a/dev-python/memory-allocator/memory-allocator-0.1.3.ebuild b/dev-python/memory-allocator/memory-allocator-0.1.3.ebuild
new file mode 100644
index 000000000000..0f679f1e9867
--- /dev/null
+++ b/dev-python/memory-allocator/memory-allocator-0.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="An extension class for memory allocation in cython"
+HOMEPAGE="https://pypi.org/project/memory-allocator/
+ https://github.com/sagemath/memory_allocator"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ # The test script tries to "import memory_allocator.test" which, so
+ # long as a memory_allocator directory exists inside CWD, will look
+ # for a memory_allocator/test.py there. But there is no such file;
+ # the "test" module is a compiled extension. To let the search fall
+ # back to the correct location, we temporarily rename the directory
+ # that misleads it.
+ mv memory_allocator mv_memory_allocator || die
+ ${EPYTHON} test.py || die
+ mv mv_memory_allocator memory_allocator || die
+}
diff --git a/dev-python/memory-allocator/metadata.xml b/dev-python/memory-allocator/metadata.xml
new file mode 100644
index 000000000000..402080770fc8
--- /dev/null
+++ b/dev-python/memory-allocator/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ This package provides a single MemoryAllocator class that makes
+ memory allocation easier in Cython. The class has familiar (cdef)
+ methods like malloc and realloc, and all allocated memory is freed
+ when the MemoryAllocator object is destroyed.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="pypi">memory-allocator</remote-id>
+ <remote-id type="github">sagemath/memory_allocator</remote-id>
+ </upstream>
+</pkgmetadata>