summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
commitd117172e3b48fc4be82b7623ffc40bb6070ef361 (patch)
tree20abd806f41d6a3c1699561a0f81279763e9253d /dev-python/memory_profiler
parent5950ab0f26bdbfcc40b68a19fd542816fecdd615 (diff)
gentoo auto-resync : 25:12:2022 - 20:05:44
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest4
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.60.ebuild55
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.61.ebuild2
3 files changed, 2 insertions, 59 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index 9fd03bf21797..0bc636232cda 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,5 +1,3 @@
-DIST memory_profiler-0.60.gh.tar.gz 142585 BLAKE2B aa7fd9e547eecadc184d4da5830c582a9a9ab9565f3dc9c763caaa7e75698ed6b499d2555e4a93b39d2f80f85fad025b84043e0812cb25dd1511f4ebf8da5a85 SHA512 407e44a410cdb4c7c8cc5ff40198c28012f8b0c6bba88d2d1612681eb621a1b802ef137be62fc64ca9e3c362ca3814433bc12169d7c3827bf97293c5bbb8bfbc
DIST memory_profiler-0.61.gh.tar.gz 144680 BLAKE2B 418ae6e7433dd58b00c8706209a7172c31ccf57d74255aa670b271bc9d76b339bd582b48886bed7b53062abd8eb421678c911b3495de4d541b949f340aad7091 SHA512 02c70a049107ad4df635e20e22eaaa91fd4e4fd29690b0a7c314e08ed6e076bbb81f85dd97924ed35f7f0133cfd3c7e55b35400449489733beb172debe592c4e
-EBUILD memory_profiler-0.60.ebuild 1795 BLAKE2B 306779b206e489492c8b02af49a7d853d390eef028ff766d5319a0164141aaa2560f64b4067d00fc25f45b0db46ce480f25b776f91ad038785baff09d5ffcb3d SHA512 95f4a018603a6a42a7c66b5b63014378d955e3b6cebc7f3a726ef93a41f169689b5eac8a7fe1187dadf9e377d2353ad9ebb5587a2bfe83ab4aabf3435dfe3a40
-EBUILD memory_profiler-0.61.ebuild 1837 BLAKE2B 38424fe50ad7f007896e47c921d39284d0960a766f29468c6896842ded89ecefeb89b9bacac7bca12843d33bfc63360986bd6ddc9a0f7b054b8580c4dca79ae3 SHA512 ffb3dfef542c0a8adeb0b2329e99d599acee674d6b72a016851dd27eb7659064d58780be27e8cbc794b76d7595c056e93b655bd540f7ea1cda21b058b8f5f051
+EBUILD memory_profiler-0.61.ebuild 1835 BLAKE2B 5c71e96befce35a76cd816931861efed780bf92cb5ff26e35e031c0a7661154accd802e316de34347ad8f43c24524ae878802e33c6ae6f0bef8fec5a30808455 SHA512 2199d0167b0083b23bf92ea00c2da26b9aa434811e98f16797f9e666fecf59343f59b25afe76ea23fa04e6b24dbed8810ee3f653a845fddb66b8b3991d3b48ae
MISC metadata.xml 548 BLAKE2B 744d692e6a44ddb587b1ae69c5f6ff48fa0f02b8acadcaee34242f810d1404fc6b3c4493a257a70b3af21850e08a17a8ee3758ae9e8af1937b645a2968b5d4c0 SHA512 b7872bfa470fb34a4d60bb9ee976d5a62122b0b701635e305988660952e695f52d9d4f0227518dc9fb337b4a3f6a95dc11b5298f1787ddd100b3f46c34f812fe
diff --git a/dev-python/memory_profiler/memory_profiler-0.60.ebuild b/dev-python/memory_profiler/memory_profiler-0.60.ebuild
deleted file mode 100644
index 65cfca08bfe4..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.60.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.org/project/memory-profiler/ https://github.com/pythonprofilers/memory_profiler"
-SRC_URI="
- https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-IUSE="examples"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-# dev-lang/mercury: collision on 'mprof'
-# https://bugs.gentoo.org/571176
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- !dev-lang/mercury"
-
-distutils_enable_tests pytest
-
-python_test() {
- "${EPYTHON}" -m memory_profiler test/test_as.py || die
- "${EPYTHON}" -m memory_profiler test/test_func.py || die
- "${EPYTHON}" -m memory_profiler test/test_gen.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
- "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
- "${EPYTHON}" -m memory_profiler test/test_nested.py || die
- "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
- "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
-
- "${EPYTHON}" test/test_exception.py || die
- "${EPYTHON}" test/test_exit_code.py || die
- "${EPYTHON}" test/test_global.py || die
- "${EPYTHON}" test/test_import.py || die
- "${EPYTHON}" test/test_memory_usage.py || die
- "${EPYTHON}" test/test_mprof.py || die
- "${EPYTHON}" test/test_precision_import.py || die
- "${EPYTHON}" test/test_stream_unicode.py || die
- "${EPYTHON}" test/test_tracemalloc.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/memory_profiler/memory_profiler-0.61.ebuild b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
index a5f150e6ca3a..2aa375ab59ac 100644
--- a/dev-python/memory_profiler/memory_profiler-0.61.ebuild
+++ b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
IUSE="examples"
# dev-lang/mercury: collision on 'mprof'