summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 13:37:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 13:37:56 +0100
commit1919539ec916b166ea3a7b6c5778c40d5bccad70 (patch)
tree8d03694e000aa8e1d2f84456dadbad899b3dbbd6 /dev-python/meson-python
parent1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (diff)
gentoo auto-resync : 28:06:2023 - 13:37:56
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.13.1.ebuild14
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 27a068a641ff..f36c7ed0bbf6 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,3 +1,3 @@
DIST meson-python-0.13.1.gh.tar.gz 69434 BLAKE2B c3442eb1c066772b80efe4e41764897df85a3581c94f9d958951af04e9ad7a01c646c7ed7f0104fbe957567e16b80c6e3744ab23b6b66a8df3cc920cb68c852f SHA512 037825eabcaec5bdb73890114ecfcfb05373bcb5e2806a8d38e4afeeecea42aa14f9c8cf0bec151bd231e2984c64608b28a1ec79640485933cd57c8895b6a305
-EBUILD meson-python-0.13.1.ebuild 1361 BLAKE2B c8027342a89492b33b6706c7c8b8fa4b9a353446a140d2b89e26cd213dc83d1a3130d23475af86956667b735549e677d8d342d2129412253427d0e01c6248969 SHA512 1e36c73cda18862498eb6fce715789cfaf9107f42fed5bf3730073a3ea1eaf561f590981f2f707a3d5198ab5e833c49a14db8c18b8ce424acce77673159c1bd6
+EBUILD meson-python-0.13.1.ebuild 1660 BLAKE2B f9f5a66077732ad1dedbf7c66342741324cbc532c4fd0478b0da824653b01915ecf549681c383adbc62f1ec80944949da754908adb75ca2b1ca4a2254b255e3a SHA512 95bca66bc253565202a67cb72618b3ce2990f7c777c67ee221eafbd6b5cc9c7ecb1a8c43ec778e491d4b1697bce1f2b2401927c885c90386bb4693f2a995a572
MISC metadata.xml 357 BLAKE2B c2b5fd8c6ad39e92970a5e6c1db8950b4850660c9a95a84063504ab75e5dd69e3ab844fcef23cb51f33493b7e522a6d26227ff48dd893c92c422badc70f3c962 SHA512 1402ace4da543de7320a1d97f44177593807d5be9f1891d8a53190581877569508c46fe6b4ce63516c7fee2d2165d59d39f44343dde18438570883da3f4ad28c
diff --git a/dev-python/meson-python/meson-python-0.13.1.ebuild b/dev-python/meson-python/meson-python-0.13.1.ebuild
index c12394d97822..d8d66b145d32 100644
--- a/dev-python/meson-python/meson-python-0.13.1.ebuild
+++ b/dev-python/meson-python/meson-python-0.13.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -33,7 +33,6 @@ RDEPEND="
BDEPEND="
>=dev-python/cython-0.29.34[${PYTHON_USEDEP}]
test? (
- dev-python/GitPython[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
@@ -53,6 +52,17 @@ python_test() {
)
unset NINJA
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken venv usage that copies pypy3 executable, making it
+ # unable to find lib_pypy
+ tests/test_editable.py::test_editable_install
+ tests/test_editable.py::test_editble_reentrant
+ tests/test_examples.py::test_spam
+ tests/test_wheel.py::test_local_lib
+ )
+ fi
+
epytest
rm -rf docs/examples/spam/build/ || die # remove artifacts